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This manual contains notices which you should observe to ensure your own personal safety, as well as to
protect the product and connected equipment. These notices are highlighted in the manual by a warning
triangle and are marked as follows according to the level of danger:

!
Danger

indicates that death, severe personal injury or substantial property damage will result if proper precautions are
not taken.

!
Warning

indicates that death, severe personal injury or substantial property damage can result if proper precautions are
not taken.

!
Caution

indicates that minor personal injury or property damage can result if proper precautions are not taken.

Note

draws your attention to particularly important information on the product, handling the product, or to a particular
part of the documentation.

The device/system may only be set up and operated in conjunction with this manual.

Only qualified personnel should be allowed to install and work on this equipment. Qualified persons are
defined as persons who are authorized to commission, to ground, and to tag circuits, equipment, and sys-
tems in accordance with established safety practices and standards.

Note the following:

!
Warning

This device and its components may only be used for the applications described in the catalog or the technical
description, and only in connection with devices or components from other manufacturers which have been
approved or recommended by Siemens.

This product can only function correctly and safely if it is transported, stored, set up, and installed correctly, and
operated and maintained as recommended.

SIMATIC� and SINEC� are registered trademarks of SIEMENS AG.

Third parties using for their own purposes any other names in this document which refer to
trademarks might infringe upon the rights of the trademark owners.

We have checked the contents of this manual for agreement with the
hardware and software described. Since deviations cannot be precluded
entirely, we cannot guarantee full agreement. However, the data in this
manual are reviewed regularly and any necessary corrections included in
subsequent editions. Suggestions for improvement are welcomed.

Technical data subject to change.
� Siemens AG 1996

�	��
�	��
� ��� �	��	
	��Copyright � Siemens AG 1996 All rights reserved

The reproduction, transmission or use of this document or its contents is
not permitted without express written authority. Offenders will be liable for
damages. All rights, including rights created by patent grant or registration
of a utility model or design, are reserved.

Siemens AG
Automation Group
Industrial Automation Systems
Postfach 4848, D-90327 Nürnberg

Siemens Aktiengesellschaft C79000-G7076-C500
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Preface to the Primer

Hold on there. You weren’t going
to continue without reading the

Preface, were you?

The Preface gives you an overview of the information contained in the Primer.
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With this Primer, we aim to show you how easily you can install the S7-300
programmable logic controller and program it with the relevant STEP 7
programming software.

The Primer supports you with:

� Simple step-by-step instructions and

� An easily understandable sample program that leads you through the
entire programming procedure and which can be used as a basis for your
own program.

If you have not yet had any experience with our SIMATIC programmable
controllers, this Primer will provide you with the information you need as a
first-time user.

The form and content of the Primer are such that you can work through it
chapter by chapter.

The individual chapters describe what you have to do in chronological order.
Our intention here is to provide you with a ‘connecting thread’ that you can
follow when installing and programming your S7-300 programmable
controller.

The following page gives you an overview of the contents of the individual
chapters to help you find your way around the Primer.

First, here’s an overview before
you start working with the

Primer!

Aims of the Primer

Structure of the
Primer

Preface to the Primer

What Does This Primer Describe?
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The individual chapters of the Primer provide you with the following
information and procedures:

� Chapter 1: Requirements for Working with the Primer

This chapter lists the hardware and software requirements for working
with the Primer.

� Chapter 2: Defining and Structuring the Control Task

Using the TLIGHT sample program, we show how you can design a
program for a specific control task and how the program is then executed
by your programmable controller.

� Chapter 3: Installing and Wiring Your S7-300

In this chapter, we explain the minimum components required to make up
an S7-300 and how you can install and wire your S7-300 and connect it to
a programming device or PC.

� Chapter 4: Working with the STEP 7 Programming Software

Here, you learn how to use the STEP 7 programming software. In
addition, you are also introduced to the STEP 7 objects with which you
will work.

� Chapter 5: Configuring and Assigning Parameters to Your S7-300

This chapter tells you how you can configure and assign parameters to
your S7-300 in order to adapt it to your requirements.

� Chapter 6: Programming Logic Blocks with STEP 7

This chapter contains examples for programming in the STEP 7
languages STL (statement list), LAD (ladder logic), and FBD (function
block diagram).

� Chapter 7: Downloading and Testing Your User Program

Finally, we show you how to proceed when you want to download your
user program to the CPU and test it.

What Does Each
Chapter Contain?

Chap. 1

Chap. 2

Chap. 3

Chap. 4

Chap. 5

Chap. 6

Chap. 7

Preface to the Primer
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Requirements for Working with the Primer

You mean to say,
this is all you need for working

with the Primer?

We have made every effort to keep the hardware and software requirements for working with
the Primer to a minimum.

1
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For working with the Primer and executing the TLIGHT sample program,
you require the following hardware components:

Component Function Illustration

Rail ... functions as a mounting rack for
an S7-300.

Power supply module (PS) ... converts the supply voltage
(120/230 VAC) to 24 VDC operating
voltage for supplying the S7-300.

CPU (central processing unit)

Backup battery (optional)

... executes the user program; 
supplies the S7-300 backplane bus
with 5 V; communicates via the MPI
(multipoint interface) with other
CPUs, or with a programming 
device/PC.

Simulator module (6ES7 374...) with
8 digital inputs and 8 digital outputs

... gives you the option of testing the
user program on startup and during
operation by simulating sensor
signals via switches and displaying
signal states at the outputs via LEDs.

MPI cable ... connects a programming
device/PC with a CPU.

Programming device (PG) with an
MPI module and pre-installed
STEP 7 software

or

... configures, assigns parameters, 
programs, and tests the S7-300 
programmable controller.

Personal computer (PC) with an MPI
module or PC/MPI cable with
pre-installed STEP 7 software

... configures, assigns parameters, 
programs, and tests the S7-300 
programmable controller.

What Hardware Do
You Need?

Requirements for Working with the Primer

Hardware Requirements
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For working with the Primer and executing the TLIGHT sample program,
you require:

� WINDOWS 95 and

� The STEP 7 software package, version 3.

STEP 7 contains a SETUP program that carries out the installation
automatically.

On-screen prompts lead you step-by-step through the entire installation
process.

What Software Do
You Need?

STEP 7 Software
Package

Requirements for Working with the Primer

Software Requirements

Please note

To work with the Primer, we assume you have already
installed the STEP 7 software package.

If you have an older version of STEP 7, you must install the
new version (see above) of our STEP 7 software.
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If you still have questions and you need additional information regarding
hardware and software requirements, our manuals may be of assistance.

Anything you can’t find in our
manuals, you will find in the

online help for STEP 7!

You Will Find Information on... In...

the hardware requirements for working with STEP 7

S7-300 Programmable Controller,
Hardware and Installation
and
S7-300, M7-300 Programmable Controller,
Module Specifications

the following manuals:

installing the STEP 7 software

Standard Software for S7 and M7
STEP 7

the following manual:

Where Can You
Find Other
References?

Requirements for Working with the Primer

Other References for This Chapter
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Defining and Structuring the Control Task

We will show you exactly how to implement a simple control system using the TLIGHT
sample program.

Your control task in the
Primer is to design a TLIGHT

control system.

2
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Using the TLIGHT sample program, we intend to show you step-by-step how
to proceed in designing a control task. You can then transfer this procedure to
your own applications.

Figure 2-1 shows you an overview of the procedure with the help of a few
questions:

What is to be controlled?

What subtasks are to be performed?

What safety requirements apply?

What other requirements apply?

Which addresses do you need?

Defining and structuring your control task

Figure 2-1 Defining and Structuring a Control Task

On the following pages, we will 
show you how you can answer the
above questions and then design

your control task.

Basic Procedure

Defining and Structuring the Control Task

How Do You Design a Control Task?
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The TLIGHT sample program to be created will control vehicle and
pedestrian traffic at a pedestrian crossing, as shown in Figure 2-2.

The TLIGHT program is to control both

� The traffic lights for vehicle traffic (traffic lights) and

� The traffic lights for pedestrian traffic (pedestrian lights).

The traffic lights are equipped with the usual red, yellow, and green signals.

The pedestrian lights each have a green and red signal as well as a
pushbutton for pedestrians to request green.

Figure 2-2 The TLIGHT Sample Program is to Control Traffic at a Pedestrian Crossing as Shown

What is to be
Controlled?

What Subtasks are
to be Performed?

Defining and Structuring the Control Task

How to Define and Structure Your Control Task
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You must take into account the following safety requirements in order to
prevent any hazard to pedestrians or drivers:

� The default setting should be green for the traffic light and red for the
pedestrian light, in order to define a safe starting point.

� If the program receives a request to change the pedestrian light to green
as a result of the pushbutton being pressed, the traffic light changes from
green to red via yellow, as shown in Figure 2-3.

Apart from the safety requirements, you must now define how long the
individual signal phases are to last and when they are to start:

� The yellow phase for vehicle traffic is to last 3 seconds.

� The red phase for vehicle traffic is to last 16 seconds and it is to start
simultaneously with the green phase for pedestrians.

� The green phase for pedestrians is to last 10 seconds.

� As soon as the green phase for pedestrians has finished, the pedestrian
signal is to change to red.

� The red/yellow phase for vehicle traffic is to last 3 seconds.

� The delay for the next green request for pedestrians is to last 1 second.

Figure 2-3 gives you a schematic overview of how the TLIGHT sample
program should work:

Red for pedestrian lights

Vehicle lights switch from green

Request for green for
pedestrian lights.

Pedestrian lights switch to green

Default setting

Green for vehicle lights

Vehicle lights switch after delay
of 6 s from red via yellow
(3 s) to green.

and back to red after 10 s.
to red (16 s).
via yellow (2 s)

Delay for next green request (1 s).

Figure 2-3 Schematic Overview of the Traffic Light Control Sequence

What Safety
Requirements
Apply?

What Other
Requirements
Apply?

Defining and Structuring the Control Task
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In order for the TLIGHT sample program to simulate a traffic light control
system on the simulator module of your S7-300, you must define the
following addresses to which you can also assign a symbolic name:

� 2 inputs (I) for requesting green for the pedestrians on both sides of the
street.

� 5 outputs (Q) for controlling the signal indicators of both sets of lights.

� 1 memory bit (M) for switching the signal after a green request from a
pedestrian.

� 5 timers (T) to determine the duration of each signal phase. The timers
each have the S5Time format.

I 0.0 and I 0.1

Q 0.5

Q 0.6

Q 0.7

Pedestrian light Vehicle light

Q 0.0

Q 0.1

Figure 2-4 Traffic Light Indicators and the Required Inputs and Outputs

Address Description
Example of Symbolic

Names

Q 0.0
Q 0.1
Q 0.5
Q 0.6
Q 0.7

Red for pedestrians
Green for pedestrians
Red for vehicles
Yellow for vehicles
Green for vehicles

Ped_Red
Ped_Green
Veh_Red
Veh_Yel
Veh_Green

I 0.0
I 0.1

Pushbutton on right-hand side of street
Pushbutton on left-hand side of street

Pushb_Right
Pushb_Left

M 0.0 Memory bit for switching the signal 
after a green request from a pedestrian

Signal_Mem

T 2
T 3
T 4
T 5

T 6

Duration of yellow phase for vehicles
Duration of green phase for pedestrians
Delay red phase for vehicles
Duration of red/yellow phase for 
vehicles
Delay next green request for pedestrians

Veh_Yel_Phase
Ped_Green_Phase
Veh_Del_Red
Veh_Red_Yel_Phase

Ped_Del_Green

Which Addresses
Do You Need?

Defining and Structuring the Control Task
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If input I 0.0 or I 0.1 is set by the pedestrian green request, the following
occurs:

� The traffic light switches from Q 0.7 (green) via Q 0.6 (yellow) to Q 0.5
(red) and

� The pedestrian light switches from Q 0.0 (red) to Q 0.1 (green)

The outputs are set alternately by the timers defined in the program.

Figure 2-5 shows the signal states of the inputs and outputs during the
TLIGHT sample program sequence:

Signal states

Q 0.5: Veh_Red

Q 0.6: Veh_Yel

2 6 10 12 14 16 18 20 22 24 26 28

Vehicle lights

Pedestrian lights

84 300

Q 0.1: Ped_Green

Time in s

I 0.0 or I 0.1:
Switch right or left

Q 0.7: Veh_Green

Q 0.0: Ped_Red

0 = off
1 = on

1
0

1
0

1
0

1
0

1
0

1
0

Figure 2-5 Signal States of the Inputs and Outputs During the TLIGHT Sample Program Sequence

Sample Program
Sequence

Defining and Structuring the Control Task
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If you still have questions and you need additional information with regard to
defining and structuring your own control task, our manuals may be of
assistance.

You will find a detailed example
in the manual below!

You Will Find Information on... In...

defining and structuring a control task and on overall
program design for your S7-300

System Software for S7-300 and S7-400
Program Design

the following manual:

Where Can You
Find Other
References?

Defining and Structuring the Control Task

Other References for This Chapter
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Defining and Structuring the Control Task
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Installing and Wiring Your S7-300

You want to install and wire
your S7-300?

No problem! You can do it
in no time!

This chapter shows you step-by-step how to proceed.

3
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There are a few simple slot rules that you need to observe when installing
your S7-300 (see Figure 3-1):

� The power supply module (PS) must always be plugged in as the first
module on the left of the DIN rail.

� The CPU is always the second module to be plugged in to the right of the
power supply module.

� Up to 8 signal modules can be plugged in to the right of the CPU.

Slot assignments on your S7-300

Simulator module
Power supply
module PS

CPU

Figure 3-1 Simple Slot Rules for Arranging the Modules

We require only one simulator module for working with the primer and for
executing our sample program.

Are There Any Slot
Rules?

Installing and Wiring Your S7-300

What Do You Need to Know Before You Start?

Please Note

You can install your S7-300 either in a flat or an upright position.

We have decided on horizontal installation, and the following
explains how.
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You can install your S7-300 with just a few adjustments as shown below:

Step Procedure Illustration

1.
Install the DIN rail and ground the
connection.

2.
Plug the bus connector into the module to be

installed (the illustration shows the CPU).

Please read on.
There’s more on the next page!

Basic Procedure

Installing and Wiring Your S7-300

How Do You Install Your S7-300?
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Step Procedure Illustration

3.
Hang each module (the illustration shows the
CPU) onto the DIN rail and swing it down.

1

3

2

4. Screw the module tight.

0.8 to 1.1 Nm

5. Insert the key into the CPU.

STOP

Now that you have installed your
S7-300, you can wire it.

Installing and Wiring Your S7-300
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The table below shows you the basic procedure for wiring your S7-300. You
should observe the assembly guidelines which are described in the manuals
listed at the end of this chapter.

!
Warning

Only wire the S7-300 when the power is switched off!

You can wire the PS 307 power supply module to the CPU 313/314/315 via
the connecting collar enclosed. The PS 307 power supply module with the
CPU 312 IFM is wired via the front connector of the integral inputs/outputs
on the CPU 312 IFM.

Step Procedure Illustration

1.
Set the voltage (120/230 VAC) 
on the power supply module.

1.

2.

2.
Wire the power supply module (PS 307) to
the CPU (311/314/315) with the connecting
collar.

0.5 to 0.8 Nm

Connecting
collar

230 V/120 V

Strain relief
clamp

4x

Overview

Installing and Wiring Your S7-300

How Do You Wire Your S7-300?
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Connect your programming device/PC to your S7-300 via an MPI cable. The
MPI cable is included with your programming device.

Figure 3-2 shows how the multipoint interfaces on the programming device
and on your S7-300 are connected by an MPI cable:

MPI cable

S7-300

Programming device

Figure 3-2 Connecting a Programming Device to an S7-300 via a Multipoint Interface

Multipoint interface (MPI)

Left side of the programming device

Figure 3-3 Left-Hand Side of the Programming Device with the Multipoint Interface

Now switch on the CPU of your S7-300 and turn the key to RUN-P.

Connecting a
Programming
Device/PC to an
S7-300

Switching On the
CPU

Installing and Wiring Your S7-300

How Do You Connect Your Programming Device/PC?
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You will find additional information regarding the installation of complex
systems in our manuals.

If you are installing a larger
system, the manuals listed 

below will help you!

You Will Find Information on... In...

� planning the mechanical and 
electrical installation of an S7-300

� addressing the S7-300 modules

� installing an S7-300

� wiring an S7-300

� installing an MPI network for communications

� memory cards for the S7-300

� spare parts for the S7-300

� the S7-300 modules

S7-300 Programmable Controller, 
Hardware and Installation
and
S7-300 and M7-300 Programmable Controllers
Module Specifications

the following manuals:

Where Can You
Find Other 
References?

Installing and Wiring Your S7-300

Other References for This Chapter
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Working with the STEP 7 Programming
Software

Now we can really get going.
Go ahead and switch on your
programming device or PC!

On the following pages, you will be introduced to the STEP 7 programming software.

4
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STEP 7 is the programming software for SIMATIC S7/M7 and therefore for
your S7-300. STEP 7 provides you with the entire functionality required for
configuring, programming, and assigning parameters to your S7-300. Our
programming software gives you effective support when solving your
automation task.

The figure below shows you the most important features of STEP 7 which
will make your task considerably easier:

STEP 7 runs under Windows 95 and
is as easy to operate as other

Windows applications!

You can work with object-orientation
using STEP 7. All objects are 

represented by symbols on the 
graphical user interface!

You will recognize the STEP 7
objects from your everyday
working world: They include

stations, modules, and programs!

STEP 7 supports you with a
user-friendly, context-sensitive online
help function that gives you valuable

information and tips!

Introduction

Working with the STEP 7 Programming Software

What is STEP 7?
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You can start up the software quite simply by double-clicking on the icon for
the SIMATIC Manager.

Result: The project window for the SIMATIC Manager opens.

NUM

File

Press F1 for help.

View Options Help

 SIMATIC Manager

ON OFF

 SIMATIC ManagerStart 15:57

Figure 4-1 The SIMATIC Manager Window

The SIMATIC Manager is the entry interface for programming with STEP 7.
It shows a hierarchical representation of all the objects in a project, which
enable you to access all the functions you require to solve your automation
task.

Starting from the SIMATIC Manager, you can:

� Configure and assign parameters to your S7-300

� Program your S7-300

Your task is to create an automation solution for a traffic light control system.
You will make it easier for yourself if you acquire and digest the following
basic information:

� What objects you require for working with STEP 7 and

� How you can arrange and handle these objects.

You will get to know these objects on the next page.

Starting Up the
Software

SIMATIC Manager

Further
Procedures

Working with the STEP 7 Programming Software

How Do You Work with STEP 7?
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The table below shows you the STEP 7 objects that you should know for the
TLIGHT programming example.

You can see from the table which symbols are assigned to the individual
objects and what they mean:

Symbol Object Description In Container

Project Represents the entirety of all data and
programs of an automation solution

Lies at the top of an object
hierarchy

SIMATIC 300 station Represents a hardware installation with
one or more programmable modules

Project

Programmable module Represents a programmable module
(CPU)

Station

S7 program Consists of the “Blocks” and “Source
Files” containers and the “Symbols”
object

Programmable module or
project

Blocks Contains the blocks in your user programS7 program

Block (offline)

Block (online)

Can be, for example:

� Logic blocks (OBs and FCs)

Blocks

You create objects such as projects via the menu command File → New....
These objects can in turn contain other objects, such as programs and blocks.
You can assign these via commands in the Insert menu. Blocks contain no
further objects. Opening a block starts the assigned editor with which you can
then edit the contents of the block.

You can change the representation of objects and set the object properties in
various dialog boxes.

Introduction

Creating Objects

Representing
Objects

Working with the STEP 7 Programming Software

Which STEP 7 Objects Should You Know?
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You have access to all the processing functions via STEP 7 objects:

And you can print and
archive objects!

You can edit and
save objects!

You can cut, copy, and
paste objects!

You can rename and
delete objects!

You can create and
open objects!

With STEP 7, you can structure a system into projects. A project contains the
entire database for an automation solution. Creating a project or a project
structure is therefore an essential prerequisite for working with STEP 7.
Figure 4-2 shows you how a project is structured:

Project Station Programmable
Module

Program

TLIGHT

S7-300

CPU 314

S7
program 1

TLIGHT
program

OB1

FC 1

Blocks Stored
Blocks

Figure 4-2 This is What a Project Structure Looks Like

On the next page, you will find out how to create a project and a station for
the TLIGHT sample program.

Actions with
Objects

The Most
Important Object 
is a ‘Project’

Working with the STEP 7 Programming Software
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For the TLIGHT sample program, you need a project structure in which you
can store the relevant data for this control task.

You have already learned on the
previous page what a project

structure looks like. Now make one
yourself!

The table below shows you step-by-step how to create a project and a station:

Step Procedure Result

1.

Click on the menu command File → New →
Project... in the SIMATIC Manager or click on 
the relevant icon in the toolbar.
In the next dialog box, enter the name ‘TLIGHT’
and click on “OK” to create the project.

The new project with the name ‘TLIGHT’ is 
displayed. You can now insert further objects.

2.

Add a station to the open project with the menu
command Insert → Hardware → SIMATIC
300 Station.
In the project window, click on the “+” in front
of the project symbol if the station is not
displayed.

The station and its name are displayed in the
project window.
You have now inserted a hardware station in the
project “TLIGHT”.

Introduction

How Do You
Proceed?

Working with the STEP 7 Programming Software

This is How You Create a Project Structure!
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If you still have questions and you need additional information on creating
projects, stations, and programs, our manuals may be of assistance.

You will find a detailed example
in the manual below!

You Will Find Information on... In...

creating projects, stations, and programs

System Software for S7 and M7 
STEP 7

the following manual:

Where Can You
Find Other
References?

Working with the STEP 7 Programming Software

Other References for This Chapter
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Configuring and Assigning Parameters
to Your S7-300

You can make all the necessary settings via the STEP 7 software.

Believe me, you don’t even
need to get out of your chair!

5
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‘Configuring’ is arranging modules in a configuration table.

Just as in your actual system, you arrange the modules on a mounting rack
using STEP 7. You can select the modules from an electronic catalog and
enter them in the relevant slot in the configuration table. The slot in the
configuration table should correspond to the real slot on the mounting rack.

STEP 7 then assigns an address to each module in the configuration table.

‘Assigning parameters’ means setting the characteristics and behavior of
modules.

Example: A CPU is a module which
can be assigned parameters. The scan
cycle monitoring time is a parameter

that you can set.

What Does
Configuring
Mean?

What Does
Assigning
Parameters Mean?

Configuring and Assigning Parameters to Your S7-300

What is Configuring and Assigning Parameters?
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Before you can enter a new configuration and assign parameters to the CPU
of your S7-300, you must have created a project and selected the object that
you want to configure (here, your SIMATIC 300 station).

To make sure that there are no ‘old’ blocks in your CPU, you should perform
a memory reset before downloading the new configuration to the CPU.

We aim to show you the basic procedure for configuring and assigning
parameters using the TLIGHT sample program. The figure below gives you
an overview of this procedure:

Procedure for configuring and assigning parameters

Configure and assign parameters to the CPU

Reset CPU memory

Save configuration table

Download the configuration to your S7-300

Figure 5-1 Procedure for Configuring and Assigning Parameters

Since you have already created
the TLIGHT project, you can start

right away with the memory
reset of your S7-300!

Prerequisites

Basic Procedure

Configuring and Assigning Parameters to Your S7-300

How to Configure and Assign Parameters
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Before downloading your configuration data to the CPU of your S7-300,
perform a memory reset of the CPU to make sure that it does not contain any
‘old’ blocks.

Please note that a memory
reset deletes all the user data

in the CPU!

The table below shows you step-by-step how to perform a memory reset on
the CPU of your S7-300:

Step Procedure Result

1.

Click on the menu command File → Open →
Accessible Nodes in the SIMATIC Manager and
select the MPI address of your CPU in the
subsequent dialog box to establish an online
connection.

An online connection to your CPU now exists.

2.
Display the current operating mode of your CPU
with the menu command PLC → Operating
Mode...

The current mode of your CPU is displayed.

3.
Set the CPU to STOP by clicking on the ‘Stop’
button and confirm with “OK”. Exit the dialog
box by clicking on “Close”.

The CPU goes to STOP.

4.

Call the ‘Memory Reset’ function with the menu
command PLC → Clear/Reset... and confirm.

The keyswitch on your CPU must be in the
position “RUN-P” or “STOP”.

The following process now takes place in the
CPU:

� The CPU is reset and the entire user program
is deleted.

� The system parameters and the CPU and
module parameters are reset to the default
settings.

� The CPU breaks off all existing connections.

Introduction

How Do You
Proceed?

Configuring and Assigning Parameters to Your S7-300

First Perform a Memory Reset of Your CPU!
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The table below shows you step-by-step how to configure and assign
parameters to your S7-300:

Step Procedure Result

1.

Select the SIMATIC 300 station (1) in your
project and call up the configuration table with
the menu command Edit → Open Object.

The configuration table appears on the screen
with the working window and the “Hardware
Catalog” window containing all the available
modules. If the hardware catalog is not displayed,
you can open it with “Ctrl + K”.

2.
In the hardware catalog, select the mounting rack
via SIMATIC 300 → RACK 300 → Rail
and drag and drop it into the working window.

A table is displayed showing the rail and its slots.

3.

Click on the table and select the detailed view of
the configuration table with the menu command
View → Details.

The detailed view of the configuration table with
an overview of the order numbers and the
module addresses appears on the screen, as
shown in Figure 5-2.

4.

In the hardware catalog, select the module you
want to use via SIMATIC 300 :

� Power supply module (PS 307 2A)

� CPU (CPU 314) and

� Simulator module (SM 323 DI8/DO8)

and drag and drop these into lines 1, 2, and 4 of
the configuration table.

The selected modules are displayed in the relevant
lines of the configuration table.

Note:

Slot 3 in the configuration table remains free since
this slot is reserved for a module that is not
required here (IM).

The configuration table is now complete.

You can now assign parameters to your CPU as described in steps 5 and 6.

You must then save the configuration and download it as described in steps 7 and 8.

5.
In the configuration table, double-click on the line
of the module you want to configure – the CPU in
this case.

A dialog box appears with information and the
assignable parameters of the CPU.

6.

Click in the dialog box on the ‘Cycle / Clock
Memory’ tab and change the set scan cycle
monitoring time to 100 ms. Exit the dialog box
with ‘OK’.

The default scan cycle monitoring time of 150 ms
has been changed to 100 ms.

7.
Save your overall configuration to the TLIGHT
project with the menu command File → Save.

Your overall configuration is saved on the hard
disk of your programming device/PC in the
TLIGHT project.

8.

Download the overall configuration to your
S7-300 with the menu command PLC →
Download → To Module....

Click on ‘OK’ in the dialog box “Select Target
Module” and confirm the preset node address in
the dialog box “Define Node Address” with
“OK”.

Your overall configuration is downloaded to the
CPU with the node address 2.

The modified parameters become effective the
next time you execute a complete restart.

How Do You
Proceed?

Configuring and Assigning Parameters to Your S7-300

How Do You Configure and Assign Parameters to Your S7-300?
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You must fill in a configuration table according to the hardware configuration
of your S7-300. The relevant position in the configuration table is assigned to
the actual slot in your mounting rack.

Figure 5-2 shows you an example of converting the actual configuration of
your S7-300 to the configuration table:

Output
Length

Slot numbers:

Detailed view of the configuration table

Physical configuration of your S7-300

Mounting rack 0

1 2

Order Number Input Address Output
Address

Slot Module MPI Address Input Length

1
2

4

PS ...

CPU ...

SM ...

6ES7...

6ES7...

6ES7...

3

4

5

6

2

This line remains blank since it is reserved for an IM!

As you can see, 
configuring your S7-300

is really quite easy!

Figure 5-2 From Your S7-300 Configuration to the Configuration Table

Configuration
Table Example

Configuring and Assigning Parameters to Your S7-300

What Does a Configuration Table Look Like?
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If you still have questions and you need additional information on
configuring and assigning parameters to your S7-300, our manuals may be of
assistance.

You really want to find out more
about configuring and
assigning parameters?

You Will Find Information on... In...

configuring and assigning parameters to your S7-300

Standard Software for S7 and M7 
STEP 7

the following manual:

Where Can You
Find Other
References?

Configuring and Assigning Parameters to Your S7-300

Other References for This Chapter
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Programming Logic Blocks with STEP 7

Programming your blocks is easy and user-friendly with STEP 7.

You want to program your
S7-300?

No problem! It’s easy too!

6
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You can program your programmable controller quite easily by creating a
user program that you download to the CPU of your S7-300. The user
program you have to create consists of different blocks which enable you to
structure your program. For the TLIGHT sample program, you require only
two blocks:

� An organization block (OB1) for cyclic program execution and

� A function (FC1) into which you enter the actual program.

An organization block (OB) is the interface between the operating system of
the CPU and your user program. The order in which the user program is
executed is defined in an OB.

A function (FC) is a logic block without ‘memory’ which can nevertheless
transfer parameters. This block is especially suitable for programming 
frequently recurring functions.

Using the TLIGHT sample program, we aim to show you the basic procedure
for programming blocks. Figure 6-1 gives you a task-oriented overview:

Procedure for programming blocks

Create blocks:

� Create FC1 and assign language editor (STL, LAD, or
FBD)

Program blocks (in STL, LAD, or FBD):

� Start language editor, declare variables and enter
program, divided into networks.

Save and download blocks:

� Save the blocks in your programming device/PC and
download them to the CPU

Figure 6-1 Basic Procedure for Programming

Introduction

What is an
Organization Block
(OB)?

What is a Function
(FC)?

Basic Procedure

Programming Logic Blocks with STEP 7

Procedure for Programming Blocks
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Program an organization block (OB1)
and a function (FC1) for the TLIGHT

sample program.

The table below shows you how to create the required function:

Step Procedure Result

1.
Open the TLIGHT project in the SIMATIC
Manager with the menu command File → Open
→ Project ....

The project window for the TLIGHT sample
program is opened offline.

2.
Open the containers of the TLIGHT project
down to the lowest level by clicking on “+” and
select the “Blocks” container.

The OB1 stored in the “Blocks” container is 
displayed offline.

3.

Insert a function with the name FC1 using the
menu command Insert → S7 Block → FC.
In the dialog box which then appears, select the
programming language you require (STL, LAD,
or FBD) and confirm with “OK”.

FC1 and OB1 are displayed offline in the project
window of the SIMATIC Manager.

Since we don’t know whether you
prefer to program in STL, LAD, or

FBD, we’ll just show you both
methods.

How Do You
Proceed?

Programming Logic Blocks with STEP 7

How Do You Create the Required Blocks?
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STL stands for Statement List and is a textual programming language in
STEP 7. The syntax of the statements is close to machine code: Instructions
or operations are followed by addresses. You can use this to program your
control task in STL for optimal memory capacity and runtime.

LAD stands for Ladder Logic and is a graphical programming language in
STEP 7. The syntax of the statements is similar to a circuit diagram and
enables you to easily follow the signal flow between conductor bars via
contacts, complex elements and coils.

FBD stands for Function Block Diagram and is also a graphic programming
language in STEP 7. The statements are represented as logic boxes, similar to
those in boolean algebra. As with the wiring diagrams in digital technology,
you can follow the signal flow by means of the boxes.

STL, LAD, and FBD are integrated into the STEP 7 Standard software. So
after you have installed STEP 7, all the editor, compiler, and test functions of
STL, LAD, and FBD are available to you.

You can change the language
setting for a block using the

View menu and you can
switch between STL, LAD, and

FBD!

STL = Statement
List

LAD = Ladder
Logic

FBD = Function
Block Diagram

STL, LAD, and
FBD are Integrated
into STEP 7

Programming Logic Blocks with STEP 7

What are STL, LAD, and FBD?
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If you double-click on the FC1 which has already been programmed, the
language editor you have assigned (STL, LAD, or FBD) will be started and a
split window appears with:

� The variable declaration table of the block in the upper half and

� The code section of the block in the lower half of the window. This is
where you write your program.

Starting STL, LAD,
and FBD

Programming Logic Blocks with STEP 7
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You do not need to fill in the
variable declaration table since the

FC1 used in the TLIGHT sample
program does not contain any

local variables!

In the code section, you enter the program for your block as STL statements
or as LAD and FBD elements in networks. The incremental STL, LAD, and
FBD editor executes a syntax check immediately after each statement or
element is entered and displays any errors in red italics. Any such syntax
errors must be corrected before saving the block.

In the TLIGHT sample program, the code section consists of several
networks, which in turn contain a list of statements or a circuit.

In the code section of a block, you can edit the block title, block comments,
network title, network comments, and STL statements or LAD/FBD elements
within individual networks, as shown in Figure 6-2:

FC1

I 0.0

I 0.1

M 0.0T 6 T 5

FC1: TLIGHT sample program

Control of traffic lights at a pedestrian crossing

Network 1: Detecting green request for pedestrians

Determine if I 0.0 or I 0.1 are set.

Network 2: green phase for vehicle traffic

If I 0.0 and I 0.1 are not set, green is free to be assigned to vehicles.

Block title

Block comments

Network title

Network comments

LAD elements

M 0.0

M 0.0 Q 0.7

Figure 6-2 Structure of the Code Section for a LAD Block

Variable
Declaration Table

Code Section

Components of the
Code Section

Programming Logic Blocks with STEP 7
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You must have created FC1 and OB1 as blocks and assigned the incremental
STL editor as the language editor.

You will find the rules for
entering STL statements in

the STEP 7 online help.

The table below shows you step-by-step how to enter STL statements:

Step Procedure Result

1.

Start the assigned STL editor by double-clicking
on FC1 in the SIMATIC Manager.

FC1 is opened and appears in a split window
with:
� The variable declaration table and
� The code section of the block.

2.
Select the menu command Insert → Network
to create a new network or click on the relevant
icon in the toolbar.

The first network is displayed in the code section
of the open FC1.

3.
Select the area below the network comment and
enter the STL statements listed below line for
line via the keyboard.

After each line is entered, it is checked for syntax
errors. Lines containing errors are displayed in red.
These must be corrected before the block is saved.

4.
Create a total of 11 networks as described above
and enter the statements listed below in the relevant
networks.

If no syntax errors are displayed (red background),
programming of FC1 is complete and you can now
save it.

5.
Save the complete and correctly created FC1
with the menu command File → Save

The block is saved on your programming
device/PC.

6.
Then program OB1 in the same way. OB1 is programmed and saved on your

programming device/PC.

Prerequisite

How Do You
Proceed?

Programming Logic Blocks with STEP 7

How Do You Program Blocks in STL?
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Enter the STL statements listed below for the TLIGHT sample program
network by network in your FC1. Proceed as described in the table. You have
already defined the required addresses in Chapter 2 of the Primer.

Network 1: Detecting green request for pedestrians
 

A(
A(
O I 0.0
O I 0.1
)
A T 6
O M 0.0
)
AN T 5
= M 0.0

Network 2: Green phase for vehicles
 

AN M 0.0
= Q 0.7

Network 3: Timer start for yellow phase for vehicles
 

A M 0.0
L S5T#3S
SI T 2

Network 4: Yellow phase for vehicles
 

A M 0.0
A(
ON T 2
O T 4
)
= Q 0.6

Network 5: Red phase for vehicles
 

A M 0.0
A T 2
= Q 0.5

Network 6: Timer start for green phase for pedestrians
 

A Q 0.5
L S5T#10S
SI T 3

Network 7: Green phase for pedestrians
 

A Q 0.5
AN T 3
= Q 0.1

STL Statements
for FC1

Programming Logic Blocks with STEP 7
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Network 8: Timer start for yellow phase delay for vehicles
 

A M 0.0
A T 3
L S5T#6S
SI T 4

Network 9: Red phase for pedestrians
 

A M 0.0
A(
ON T 2
O T 3
)
ON M 0.0
= Q 0.0

Network 10: Timer start for red/yellow phase for vehicles
 

A M 0.0
A T 4
L S5T#3S
SI T 5

Network 11: Timer start for green request delay
 

A Q 0.7
L S5T#1S
SI T 6

Enter the STL statement below for the TLIGHT sample program in your
OB1. Proceed as described in the table on the previous page.

Network 1: FC1 call for traffic light control
 

CALL FC1

STL Statements
for OB1

Programming Logic Blocks with STEP 7
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You have created OB1 and FC1 as blocks and you have assigned the
incremental LAD editor as the language editor.

If you double-click on the FC1 which has already been programmed in the
SIMATIC Manager, the assigned LAD editor is started and you can program
the block.

A LAD network or circuit can consist of several elements in several
branches. All elements and branches of such a network must be linked
together. The left conductor bar does not count as a connection.

There are some rules to observe when programming in LAD:

� Each LAD network must be terminated with a coil or box.

� Branches that could result in current flow in the opposite direction cannot
be edited.

� Branches that would cause a short-circuit cannot be edited.

Don’t worry.
If you make any errors in entering

the LAD statements, error messages
will bring them to your attention!

Prerequisite

Starting the LAD
Language Editor

Rules for Entering
LAD Elements

Programming Logic Blocks with STEP 7

How Do You Program Blocks in LAD?
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There are the following methods for inserting LAD elements:

� You can enter NO contacts, NC contacts, or coils via function keys F2, F3,

or F7 or you can select the icons for NO contacts, NC contacts, or coils
from the toolbar.

� You can select and insert LAD elements with the menu command Insert
→  LAD Element.

� In addition, you can select and insert program elements, for example,
timers, from a catalog. Open the “Program Elements” catalog with the
keys “Ctrl + K” or using the corresponding icon in the toolbar.

The table below shows you step-by-step how to enter LAD elements:

Step Procedure Result

1.
Start the assigned LAD editor by double-clicking
on FC1 in the SIMATIC Manager.

FC1 is opened and a split window appears with:
� The variable declaration table and
� The code section of the block.

2.
Select the menu command Insert→ Network to
create a new network or click on the relevant icon
in the toolbar.

The first network is displayed in the code section
of the open FC1. It contains a branch with a coil.

3.

Select the area below the network comment and
enter the LAD elements listed below via the
menu command Insert → LAD Element or
using the corresponding function keys.

After each element is entered, it is checked for
syntax errors. Elements containing errors are
displayed in red. These must be corrected before
the block is saved.

4.
Create a total of 11 networks as described above
and enter the elements in the relevant networks.

If no syntax errors are displayed (red background),
programming of FC1 is complete and you can now
save it.

5.
Save the complete and correctly created FC1
with the menu command File → Save

The block is saved.

6.
Then program OB1 in the same way. OB1 is programmed and saved on your

programming device/PC.

Methods of
Entering LAD
Elements

How Do You
Proceed?

Programming Logic Blocks with STEP 7
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Enter the LAD elements listed below for the TLIGHT sample program
network by network in your FC1. Proceed as described in the table. You have
already defined the required addresses in Chapter 2 of the Primer.

Network 1: Detecting green request for pedestrians

I0.0

M0.0

I0.1

M0.0T6 T5

Network 2: Green phase for vehicles

M0.0 Q0.7

Network 3: Timer start for yellow phase for vehicles

M0.0

S5T#3S

T2

??.?

??.?

S_ODT

S

TV

R BCD

Q

BI

Network 4: Yellow phase for vehicles

M0.0 Q0.6

T4

T2

Network 5: Red phase for vehicles

M0.0 Q0.5T2

Network 6: Timer start for green phase for pedestrians

Q0.5

S5T#10S

T3

??.?

??.?

S_ODT

S

TV

R BCD

Q

BI

Network 7: Green phase for pedestrians

Q0.5 Q0.1T3

LAD Elements for
FC1

Programming Logic Blocks with STEP 7
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Network 8: Timer start for yellow phase delay for vehicles

M0.0 T3

S5T#6S

T4

??.?

??.?

S_ODT

S

TV

R BCD

Q

BI

Network 9: Red phase for pedestrians

M0.0 Q0.0

M0.0

T2

T3

Network 10: Timer start for red/yellow phase for vehicles

M0.0 T4

S5T#3S

T5

??.?

??.?

S_ODT

S

TV

R BCD

Q

BI

Network 11: Timer start for green request delay

Q0.7

S5T#1S

T6

??.?

??.?

S_ODT

S

TV

R BCD

Q

BI

Enter the LAD elements below for the TLIGHT sample program in your
OB1. Proceed as described in the table on the previous page.

Network 1: FC1 call for traffic light control

??.?

FC1

EN ENO

LAD Elements for
OB1

Programming Logic Blocks with STEP 7
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You have created OB1 and FC1 as blocks and you have assigned the
incremental FBD editor as the language editor.

If you double-click on the FC1 which has already been programmed in the
SIMATIC Manager, the assigned FBD editor is started and you can program
the block.

An FBD network can consist of several elements in several branches. All
elements and branches of such a network must be linked together.

There are some rules to observe when programming in FBD:

� Each FBD network must end with either an assignment or a box.

� The following FBD elements cannot be used to end a network: compare
boxes (-=-), midline outputs (-#-), and positive (-P-) or negative (-N-)
edge evaluation.

� You can attach standard boxes (flip-flops, counters, math instructions,
etc.) to boxes with binary logic.

� You cannot program unlinked logic operations with separate outputs in a
network.

Don’t worry.
If you make any errors in entering

the FBD statements, error messages
will bring them to your attention!

Prerequisite

Starting the FBD
Language Editor

Rules for Entering
FBD Elements

Programming Logic Blocks with STEP 7

How Do You Program Blocks in FBD?
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The following methods are available for inserting FBD elements:

� You can insert AND boxes, OR boxes, OUTPUT boxes, and insert and
negate inputs using the function keys F2, F3, F7, F8, or F9. Alternatively,
you can select the required elements from the toolbar.

� You can select and insert FBD elements with the menu command Insert
→ FBD Element.

� In addition, you can select and insert program elements, for example,
timers, from a catalog. Open the “Program Elements” catalog with the
keys “Ctrl + K”, or with the corresponding icon in the toolbar.

The table below shows you step-by-step how to enter FBD elements:

Step Procedure Result

1.
Start the assigned FBD editor by double-clicking
on FC1 in the SIMATIC Manager.

FC1 is opened and a split window appears with:
� The variable declaration table and
� The code section of the block.

2.
Select the menu command Insert→ Network to
create a new network or click on the relevant icon
in the toolbar.

The first network is displayed in the code section
of the open FC1. It contains a branch with a coil.

3.

Select the area below the network comment and
enter the FBD elements listed below via the
menu command Insert → FBD Element or
using the corresponding function keys.

After each element is entered, it is checked for
syntax errors. Elements containing errors are
displayed in red. These must be corrected before
the block is saved.

4.
Create a total of 11 networks as described above
and enter the elements in the relevant networks.

If no syntax errors are displayed (red
background), programming of FC1 is complete
and you can now save it.

5.
Save the complete and correctly created FC1
with the menu command File → Save

The block is saved.

6.
Then program OB1 in the same way. OB1 is programmed and saved on your

programming device/PC.

Methods of
Entering FBD
Elements

How Do You
Proceed?

Programming Logic Blocks with STEP 7
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Enter the FBD elements listed below for the TLIGHT sample program
network by network in your FC1. Proceed as described in the table. You have
already defined the required addresses in Chapter 2 of the Primer.

Network 1: Detecting green request for pedestrians

M0.0

>=1
&I0.0

I0.1

T6

M0.0

>=1

&

T5

=

Network 2: Green phase for vehicles

M0.0

& =

Q0.7

Network 3: Timer start for yellow phase for vehicles

S5T#3S

T2

M0.0

??.?

???

???

S_ODT

S

TV

R

BI

BCD

Q

Network 4: Yellow phase for vehicles

>=1

T4

T2 M0.0
Q0.6

&

=

Network 5: Red phase for vehicles

M0.0
Q0.5

&

=
T2

Network 6: Timer start for green phase for pedestrians

S5T#10S

T3

Q0.5

??.?

???

???

S_ODT

S

TV

R

BI

BCD

Q

Network 7: Green phase for pedestrians

Q0.5
Q0.1

&

=
T3

FBD Elements for
FC1

Programming Logic Blocks with STEP 7
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Network 8: Timer start for yellow phase delay for vehicles

M0.0

&

T3

S5T#6S

T4

??.?

???

???

S_ODT

S

TV

R

BI

BCD

Q

Network 9: Red phase for pedestrians

Q0.0

>=1
M0.0 >=1

&
T2

=T3

M0.0

Network 10: Timer start for red/yellow phase for vehicles

M0.0

&

T4

S5T#3S

T5

??.?

???

???

S_ODT

S

TV

R

BI

BCD

Q

Network 11: Timer start for green request delay

S5T#1S

T6

Q0.7

??.?

???

???

S_ODT

S

TV

R

BI

BCD

Q

Enter the FBD elements below for the TLIGHT sample program in your
OB1. Proceed as described in the table on the previous page.

Network 1: FC1 call for traffic light control

??.?

FC1

EN ENO

FBD Elements for
OB1

Programming Logic Blocks with STEP 7



6-18
Primer: S7-300 Programmable Controller, Quick Start

C79000-G7076-C500-01

If you still have questions and you need additional information regarding
programming your blocks in STL, LAD, and FBD, our manuals may be of
assistance.

Refer to our manuals if you want
to know more!

You Will Find Information on... In...

programming blocks in STL

Statement List (STL) for
S7-300/S7-400 Programming

the following manual:

programming blocks in LAD

Ladder Logic (LAD) for
S7-300/S7-400 Programming

the following manual:

programming blocks in FBD

Function Block Diagram (FBD)
for S7-300/S7-400 Programming

the following manual:

Where Can You
Find Other 
References?

Programming Logic Blocks with STEP 7

Other References for This Chapter
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Downloading and Testing Your User
Program

When your program has been downloaded and tested, it can be executed.

If you have done everything
correctly, you can already

look forward to
success!

7
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You cannot test your program until you have downloaded it to the CPU of
your S7-300.

You can download either individual blocks or the complete user program to
the CPU of your programmable controller. Only individual blocks can be
tested.

We aim to show you the basic procedure for downloading and testing using
the TLIGHT sample program. The figure below gives a task-oriented
overview:

Procedure for downloading and testing your program

Download the user program to the CPU

Testing an STL, LAD, or FBD block:

� Open the block online

� Define the settings for the test display

� Define the trigger conditions

� Select the test environment

� Start and stop the test

Figure 7-1 Procedure for Downloading and Testing the User Program

You know our system by now.
We will now describe the

individual tasks one after the other.

Introduction

Basic Procedure

Downloading and Testing Your User Program

Basic Procedure for Downloading and Testing
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The following prerequisites must be fulfilled before you can download the
user program to your S7-300:

� There must be an online connection between your programming device
and your S7-300.

� The program to be downloaded must have been compiled without errors.

� The CPU of your S7-300 must be in the STOP state.

To test individual blocks, you must always load OB1 with all the blocks
called in it. These blocks must be in reverse call order.

For the TLIGHT sample
program, download the FC1 you

have created and the OB1 to your
CPU.

The table below shows you the procedure for downloading your user
program:

Step Procedure Result

1.

Select FC1 and OB1 in the project window of
the SIMATIC Manager (offline view) in the
“Blocks” container while holding the SHIFT key
down, and select the menu command PLC →
Download.

Both blocks are downloaded to the CPU of your
S7-300.

2.

Select the menu command View → Online and
open the containers of the TLIGHT project up to
“S7 Program” (online). Change the operating
mode of the CPU with the menu command PLC
→ Operating Mode...

Click on “Complete Restart” in the dialog box
which then appears, and then on “OK” and
“Close”.

The CPU goes to RUN via complete restart.

The TLIGHT sample program you have created
will now be executed cyclically.

Prerequisites

What to Load, and
Order of Calls

How Do You
Proceed?

Downloading and Testing Your User Program

How Do You Download the User Program to Your S7-300?
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Regardless of whether you want to test a block created in STL, LAD, or
FBD, you can always:

� Define the trigger condition,

� Select the test environment and

� Define the settings for the test display.

We will explain the meanings of
these settings below!

When you set the trigger condition, you set the call environment for the
block to be tested. The test function is only executed if the trigger condition
set is also fulfilled. You can choose between three different settings, as
shown in Figure 7-2:

Block Call Environment

Cancel

Trigger Condition

OK Help

No Condition

Call Path 1st Block:

2nd Block:

3rd Block:

Block Status: FC1

Open Data Blocks

DB1 Number:

DB2 Number:

Figure 7-2 Defining the Trigger Condition

For the sample program, the default setting ‘No Condition’ applies since the
call environment of the block to be tested is not important.

Introduction

Meaning of the
Trigger Condition

Downloading and Testing Your User Program

What Do You Have to Know about Testing?
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You can choose between the two online test situations ‘Process’ and
‘Laboratory’ in which you can test your program;

� With the ‘Process’ test environment, the status of statements during a loop
run is only detected on the first loop run.

� With the ‘Laboratory’ test environment, the status of statements during a
loop run is detected on every loop run.

For our TLIGHT sample program, we will use the ‘Process’ test environment
that has already been set as the default setting.

For testing your STL program, you can select the status fields you want to
have displayed for the STL program status.

For the TLIGHT sample program, select status bit, result of logic operation
(RLO) and standard status for display. These are the default settings. You can
make this selection by clicking on the ‘Default’ button.

For testing your LAD and FBD program, you can define how you want to
display the signal flow within the networks of a block. You can select color
and line thickness for two possible cases:

� ‘Status not fulfilled’: In this case, the conditions along the current path
have not been fulfilled; no current is flowing (broken line).

� ‘Status fulfilled’: In this case the conditions along the current path have
been met; current is flowing (unbroken line).

Now that you know the different
settings available, you can test your

program!

Meaning of the
Test Environment

Setting the Test
Display for STL

Setting the Test
Display for LAD
and FBD

Downloading and Testing Your User Program
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You test your STL program by displaying the program status for each STL
statement in the status fields you have selected. Program status display is
updated cyclically and only displayed for the area visible to the STL editor.

In order to be able to display the program status, the following prerequisites
must be fulfilled:

� You must have saved the block without errors and downloaded it to the
CPU.

� The CPU is in RUN and the user program is running.

� You must open the block to be tested online.

The table below shows you how to test an STL program:

Step Procedure Result

1.

Select the “Blocks” container in your online
project “TLIGHT”.
In the right-hand window, select the block you
want to test (here FC1), and open the block with
the menu command Edit → Open Object.

FC1 is opened online.

2.

Select the menu command Debug → Call
Environment...  and click ‘No Condition’ as the
trigger condition in the dialog box which follows.
Close the dialog box with “OK”.

This means that you have selected no trigger
condition for the call environment of the block.

3.
Select the ‘Process’ test environment via the menu
command Debug → Test Environment →
Process.

This means that the status of the statements for
your program test will only be detected on the first
loop run.

4.

In the ‘LAD/STL/FBD’ dialog box, select the
‘STL’ tab with the menu command Options →
Customize... and click here on  ‘Default’. Exit the
dialog box with “OK”.

This defines the options for the STL program test.
Status bit, RLO, and standard status will be
displayed.

5.
Start recording the program status with the menu
command Debug → Monitor

The STL program status is displayed in the code
section of FC1 in the form of a table.

6.
Stop recording the program status with the same
menu command Debug → Monitor .

Display of the STL program status is switched off
again.

Introduction

Prerequisites

How Do You
Proceed?

Downloading and Testing Your User Program

How Do You Test Your STL Program?
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The program status is only displayed for the area visible to the editor.

Netzwerk 1:

RLO STA STANDARD

A( 0 1 0
A( 0 1 0
O I 0.0 0 0 0
O I 0.1 0 0 0
) 0 1 0
A T 6 0 1 0
O M 0.0 0 0 0
) 0 1 0
AN T 5 0 0 0
= M 0.0 0 0 0

RLO STA STANDARD

AN M 0.0 1 0 0
= Q 0.7 1 1 0

Network 2 : Green phase for vehicles

Network 1: Detecting green request for pedestrians

Figure 7-3 Example of Displaying the Program Status in STL

And that’s it. That’s how quickly you get
successful results as promised with our

S7-300:
an executable user program in STL!

Displaying the
Program Status in
STL

Downloading and Testing Your User Program
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You can test your LAD program by defining how you want to display the
signal flow within the networks of a block.

To display the signal flow, the following prerequisites must be fulfilled:

� You must have saved the block without errors and downloaded it to the
CPU.

� The CPU is in RUN and the user program is running.

� You must open the block to be tested online.

The table below shows you how to test a LAD program:

Step Procedure Result

1.

Select the “Blocks” container in your online
project “TLIGHT”.

In the right-hand window, select the block you
want to test (here FC1), and open it with the menu
command File → Open Object.

FC1 is opened online.

2.

Select the menu command Debug → Call
Environment... and click ‘No Condition’ as the
trigger condition in the dialog box which follows.
Close the dialog box with “OK”.

This means that you have selected no trigger
condition for the call environment of the block.

3.
Select the ‘Process’ test environment via the menu
command Debug → Test Environment →
Process.

This means that the status of the statements for
your program test will only be detected on the
first loop run.

4.

In the ‘STL/LAD/FBD’ dialog box, select the
‘LAD/FBD’ tab with the menu command
Options → Customize... and click here on the
settings you want for color and line thickness.
Exit the dialog box with “OK”.

This defines the options for the LAD program
test. Current flow is displayed in the colors and
line thicknesses selected.

5.
Start recording the program status with the menu
command Debug → Monitor

The LAD program status is displayed in the code
section of FC1 in the form of a signal flow.

6.
Stop recording the program status with the same
menu command Debug → Monitor .

Display of the LAD program status is switched
off again.

Introduction

Prerequisites

How Do You
Proceed?

Downloading and Testing Your User Program

How Do You Test Your LAD Program?
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The program status is only displayed for the area visible to the editor.

Network 1:

Network 2 : Green phase for vehicles

I 0.0

I 0.1

M 0.0

M 0.0 Q 0.7

T 6 T 5

M 0.0

Detecting green request for pedestrians

Figure 7-4 Example of Displaying the Program Status in LAD

And that’s it. That’s how quickly you get
successful results as promised with our

S7-300:
an executable user program in LAD!

Displaying the
Program Status in
LAD

Downloading and Testing Your User Program
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You can test your FBD program by defining how you want to display the
signal flow within the networks of a block.

To display the signal flow, the following prerequisites must be fulfilled:

� You must have saved the block without errors and downloaded it to the
CPU.

� The CPU is in RUN and the user program is running.

� You must open the block to be tested online.

The table below shows you how to test an FBD program:

Step Procedure Result

1.

Select the “Blocks” container in your online
project “TLIGHT”.

In the right-hand window, select the block you
want to test (here FC1), and open it with the menu
command File → Open Object.

FC1 is opened online.

2.

Select the menu command Debug → Call
Environment... and click ‘No Condition’ as the
trigger condition in the dialog box which follows.
Close the dialog box with OK.

This means that you have selected no trigger
condition for the call environment of the block.

3.
Select the ‘Process’ test environment via the menu
command Debug → Test Environment →
Process.

This means that the status of the statements for
your program test will only be detected on the
first loop run.

4.

In the ‘STL/LAD/FBD’ dialog box, select the
‘LAD/FBD’ tab with the menu command
Options → Customize... and click here on the
settings you want for color and line thickness.
Exit the dialog box with OK.

This defines the options for the FBD program
test. Current flow is displayed in the colors and
line thicknesses selected.

5.
Start recording the program status with the menu
command Debug → Monitor

The FBD program status is displayed in the code
section of FC1 in the form of a signal flow.

6.
Stop recording the program status with the same
menu command Debug → Monitor .

Display of the FBD program status is switched off
again.

Introduction

Prerequisites

How Do You
Proceed?

Downloading and Testing Your User Program

How Do You Test Your FBD Program?
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The program status is only displayed for the area visible to the editor.

Detecting green request for pedestrians

Network 2 : Green phase for vehicles

M0.0

>=1
&I0.0

I0.1

T6

M0.0

>=1

&

T5

=

M0.0

& =

Q0.7

Network 1:

Figure 7-5 Example of Displaying the Program Status in FBD

And that’s it. That’s how quickly you get
successful results as promised with our

S7-300:
an executable user program in FBD!

Displaying the
Program Status in
FBD

Downloading and Testing Your User Program
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If you still have questions and you need additional information on
downloading and testing your user program, our manuals may be of
assistance.

Just refer to the manual below
if you need additional

information!

You Will Find Information on... In...

how to download and test your user program

Standard Software for S7 and M7
STEP 7

the following manual:

Where Can You
Find Other
References?

Downloading and Testing Your User Program

Other References for This Chapter
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Glossary

A

An address is part of a STEP 7 statement and specifies what the processor
should execute the instruction on. Addresses can be absolute or symbolic.

An automation system is a programmable logic controller (PLC) in the case
of SIMATIC S7, a SIMATIC C7 control system (PLC with integrated
operator panel), or a SIMATIC M7 automation computer.

B

The backplane bus of a SIMATIC S7 programmable logic controller supplies
the plugged-in modules with the internal operating voltage and enables data
exchange between modules. In the S7-400, the backplane bus is divided into
the I/O bus (P bus) and the communication bus (C bus). In the S7-300, the
backplane bus has a modular design in the form of U rails that each connect
two modules with each other.

Blocks are part of the user program and can be distinguished by their
function, their structure, or their purpose. STEP 7 provides the following
types of blocks:

� Logic blocks (FB, FC, OB, SFB, SFC)

� Data blocks (DB, SDB)

� User-defined data types (UDT)

Address

Automation
System

Backplane Bus

Block
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C

The CPU is the central module in the programmable controller consisting of
a control unit, arithmetic unit, memory, operating system, and interfaces to
the signal modules and function modules.

When a CPU starts up (for example, when the mode selector is moved from
STOP to RUN or when power is turned on), before cyclic program processing
starts (OB1), either the organization block OB101 (restart; only in the
S7-400) or OB100 (complete restart) is processed first. In a complete restart
the process-image input table is read in and the STEP 7 user program
processed starting with the first statement in OB1.

F

According to the International Electrotechnical Commission’s IEC 1131–3
standard, functions are logic blocks without static data. A function allows
you to pass parameters in the user program, which means they are suitable
for programming complex functions that are required frequently, for
example, calculations.

I

An instruction is part of a STEP 7 statement and specifies what the processor
should do.

L

In SIMATIC S7, a logic block is a block that contains part of the STEP 7 user
program. The other type of block is a data block which contains only data.
The following list shows the types of logic blocks:

� Organization block (OB)

� Function block (FB)

� Function (FC)

� System function block (SFB)

� System function (SFC)

Central Processing
Unit (CPU)

Complete Restart

Function (FC)

Instruction

Logic Block

Glossary
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M

The memory reset function deletes the following memories in the CPU:

� Work memory

� Read/write area of the load memory

� System memory with the exception of the MPI parameters and the
diagnostic buffer

The multipoint interface is the programming device interface in SIMATIC
S7. It allows a number of programming devices, text display operator
interfaces, and operator panels to be accessed from a central point. The nodes
on the MPI can communicate with each other.

N

A network consists of one or more connected subnets (for example, Industrial
Ethernet, PROFIBUS, MPI) with any number of nodes. Several networks can
exist side by side.

O

Organization blocks form the interface between the CPU operating system
and the user program. The sequence in which the user program should be
processed is laid down in the organization blocks.

P

The signal states of the digital input and output modules are stored in the
CPU in a process image. There is a process-image input table (PII) and a
process-image output table (PIQ).

A personal computer with a special compact design, suitable for industrial
conditions. A programming device is completely equipped for programming
the SIMATIC programmable logic controllers.

A project is a container for all objects in an automation task, independent of
the number of stations, modules, and how they are connected in a network.

Memory Reset
(MRES)

Multipoint
Interface (MPI)

Network

Organization Block
(OB)

Process Image

Programming
Device (PG)

Project

Glossary
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S

An S7 program is a container for blocks, source files, and charts for S7
programmable modules.

The CPU goes through the STARTUP mode during the transition from the
STOP mode to the RUN mode. It can be set using the mode selector, or
following power-on, or by an operation on the programming device.

A symbol is a name defined by the user, taking syntax rules into
consideration. This name can be used in programming and in operating and
monitoring once you have defined it (for example, as a variable, a data type,
a jump label, or a block).
Example: Address: I 5.0, Data Type: BOOL, Symbol: Emer_Off_Switch

T

Timers are an area in the system memory of the CPU. The contents of these
timers is updated by the operating system asynchronously to the user
program. You can use STEP 7 instructions to define the exact function of the
timer (for example, on-delay timer) and start processing it (Start).

U

The user program contains all the statements and declarations and the data
required for signal processing to control a plant or a process. The program is
linked to a programmable module (for example, CPU, FM) and can be
structured in the form of smaller units (blocks).

S7 Program

Startup

Symbol

Timer (T)

User Program

Glossary
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Index

A
Actions with objects, 4-5
Assigning parameters, 5-2
Assigning parameters to the S7-300, 5-5
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