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Introduction

This guide takes you through a specific example to set up a working application.
This way you will get to know the basic hardware  and software functions of your
CPU.

You should expect to spend between one and two hours on this example,
depending on your level of experience.

Applicability:

This guide applies to the following CPUs:

CPU Order no. You will need a 
micro memory card
(MMC) in order to

As of version

(MMC) in order to
use the following

CPUs
Firmware Hardware

312 6ES7 312-1AD10-0AB0 X V2.0.0 01

312 IFM 6ES7 312-5AC02-0AB0

6ES7 312-5AC82-0AB0

V1.1.0

V1.1.0

01

01

313 6ES7 313-1AD03-0AB0 V1.1.0 01

314 6ES7 314-1AE04-0AB0
6ES7 314-1AE84-0AB0

V1.1.0

V1.1.0

01

01

314 6ES7 314-1AF10-0AB0 X V2.0.0 01

314 IFM 6ES7 314-5AE10-0AB0 V1.1.0 01

315 6ES7 315-1AF03-0AB0 V1.1.0 01

315–2 DP 6ES7
315-2AG10-0AB0

X
V2.0.0

01

315–2 DP 6ES7 315-2AF03-0AB0

6ES7 315-2AF83-0AB0

V1.1.0

V1.1.0

01

01

316-2 DP 6ES7
316-2AG00-0AB0

V1.1.0
01

317-2 DP 6ES7 317-2AJ10-0AB0 X V2.1.0 01

318-2 DP 6ES7 318-2AJ00-0AB0 V3.0.0 03

The following requirements must be fulfilled:

You need to have a basic understanding of electronics/electrical engineering, and
have experience of working with Microsoft Windows.
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!
Warning

When using the S7–300 as a component of plants and systems, you may be
required to follow certain rules and regulations according to the specific
application. Please note the applicable safety and accident prevention regulations,
such as IEC 204 (emergency stop systems).

Non-compliance with these regulations can result in serious injury and damage to
both machinery and equipment.
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Materials and Tools Required

Quantity Item Order number (Siemens)

1 Rail e.g.  6ES7 390-1AE80-0AA0

1 Power supply (PS) e.g.  6ES7 307-1EA00-0AA0

1 Central processing unit (CPU) e.g.  6ES7 312-1AD10-0AB0

1 Micro Memory Card (MMC) 

Please note: 
You must have an MMC in order to use certain CPUs 
(see Applicability)

e.g.  6ES7 953-8LL00-0AA0

1 Digital input module (DI) with bus connector e.g. 6ES7 321-1BH02-0AA0

1 Digital output module (DO) with bus connector e.g. 6ES7 322-1BH01-0AA0

2 Multipin front connector with screw-type contacts e.g. 6ES7 392-1AM00-0AA0

1 • Programming device (PG) with MPI interface and
STEP 7 software version � 5.1 + SP 4 installed and
PG cable or

• PC with suitable interface card

Depends on configuration

Various M6 screws and nuts (length depends on installation
location) with suitable screwdriver / wrench

Standard

1 Screwdriver with 3.5 mmblade Standard

1 Screwdriver with 4.5 mmblade Standard

1 Side cutter and cable stripper Standard

1 Crimp tool Standard

X m Cable with 10 mm2 cross-section for grounding the rail
and suitable cable lug for M6 screw. Length of cable
depends on local requirements.

Standard

Approx.
2 m

Flexible cable with 1 mm2 cross-section and suitable
ferrules with insulated collar, length 6 mm

Standard

X m 3-core flexible power cable (AC 230/120 V) with
shock-proof plug; length dependant on local
requirements, with suitable
ferrules and insulating collar.

Standard

2 Single–pole ON switch (24 V) Standard
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CPUPS DI DO

Rail

LEDs MC/MMC

For setting the line voltage

 Power supply ON / OFF

Mode selector switch

PG cable for connecting
to the MPI interface

Programming device (PG)
with STEP 7 software

Sample layout (certain details of the CPUs may differ from the above illustration)

Wiring the power supply and CPU (front cover open)

220V/ 120V

L+

M

L+

M

L+

M L+

M D
C

 2
4V

Strain relief Connecting cables between the PS and CPU

Removable power supply connection

MPI interface for connecting to the PG

Power supply (PS) CPU

Layout of the example
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Functionality of the example

The output cannot switch (i.e. so that  the diode on the output module lights up)
until the switches are pressed.
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1. Installation

Figure Installing and Grounding the Rail

1.

1. Screw the rail in position (screw size: M6). 
Make sure that there is a clearance of at least
40 mm above and below the rail.

If you fasten the rail to a grounded metal plate or
device support, make sure there is a low-resistance
connection between the rail and 
the base

2.

the base.

2. Connect the rail to the protective conductor.
There is an M6 protective conductor screw on the
rail 
for this purpose.

Minimum cross-section of the cable to the protective
conductor: 10 mm2.

Figure Attaching the Modules on the Rail

CPU

1. Attach the power supply. Push it to
the left until it reaches the rail’s
grounding screw, and then screw in
place.

2. Connect to the other modules by
plugging a bus connector into the
CPU (see detail).

12

CPU

3

3. Attach the CPU (1).

4. Push it up against the module on
the
left (2)

5. and tip it downward (3).

CPU

6. Screw the modules hand-tight onto
the rail.

7. If you are using a CPU with an
MMC,
insert the memory card into the
slot.

8. Now fit the digital input module and

digital output module to the right of
the CPU by repeating steps 1 to 6.
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2. Wiring

!
Warning

You may come into contact with live wires that are connected to the power supply.
Make sure that the S7-300 is completely disconnected before you start wiring.

Wiring the Power Supply and the CPU

Step Wiring the power supply and CPU

1 Open the front panels of the power supply and the CPU.

2 Detach the strain relief clip from the power supply.

3 Strip the flexible power cable, crimp on the ferrules and connect
them to the power supply.
(Blue to terminal M, black to terminal L1, protective conductor to terminal PE)

4 Screw the strain relief clamp in place.

5 Now wire the power supply to the CPU using the 
1 mm2 cross-section flexible cable.

Strip the ends to approx. 6 mm and crimp on the ferrules. 
Connect terminals L+ and M on the power supply to those on the CPU.

6 Check that the line voltage selector switch is set to the correct line voltage.

The power supply is set at the factory to a line voltage of AC 230 V. To change the voltage,
remove the protective cap with a screwdriver, set the switch to the required line voltage and
replace the protective cap.

Wiring the Digital Input and Output Modules

Step Wiring the Front Connectors of the DI and DO

1 Open the front panels of the digital input and output modules.

2 Push front connectors into the DI and the DO until they snap into position. The front
connectors still stick out of the module, and thus have no contact with the module, in this wiring
position.

3 Cut around 10 wires (1mm2) to length (20 cm), and attach ferrules to the ends.

4 Wire the front connector for the digital input module as follows:

Terminal L+ to terminal L+ on the power supply; terminal M to terminal M on the power supply

Terminal 3 to the first connection of switch 1;

Terminal 4 to the first connection of switch 2

Connect the two unassigned connections on switches 1 and 2 to L+ on the power supply.

5 Wire the front connector for the digital output module as follows:

Terminal L+ to terminal L+ on the power supply; terminal M to terminal M on the power supply

6 Lead the wires downwards out of the front connectors.
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Wiring the Front Connectors of the DI and DOStep

7 Press the release button on the front connector at the top of the module. At the same time,
push the front connector into the module until the release button snaps back into its initial
position.

Please note: If you are using 40-pin front connectors, they must also be fixed using the fixing
screw in the center of the front connector.

8 Close the front panels of the digital input and output modules and the power supply.

3. Commissioning the Hardware

Step Tasks Result:

1 Connect the programming device to the CPU using the programming device cable. If you use a
cable with
PROFIBUS connectors, you will have to switch on the terminating resistors in the connectors.
Close the front flap on the CPU and set the mode selector switch to STOP.

2 Connect the power cable to the power supply and
switch on the power supply module.

The DC24V-LED lights up on the
power supply module.

All the LEDs on the CPU light up brie-
fly; the SF LED and the DC5V LED
remain on. The STOP LED starts to
flash slowly, prompting a memory re-
set.

3  Now insert either the micro memory card (MMC)
or the back–up battery into your CPU, depending on the CPU type.

4 Reset the CPU memory as follows:

– Press the mode selector switch to MRES. Hold the switch in this position until the
STOP LED lights up for the second time and stays on. Then release the mode selector
switch.

– Within 3 seconds, press the mode selector switch back to MRES. The STOP LED
starts to flash rapidly and the CPU memory is reset. You can now release the mode
selector. When the STOP LED lights up permanently again, the CPU memory reset is
complete.

5 Start up the programming device and start SIMATIC
Manager from the Windows desktop.

A SIMATIC Manager window opens.

6 Activate switch 1. The LED for the first input lights up.

7 Activate switch 2. The LED for the second input lights
up.
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4. Configuring the Hardware in the STEP 7 Hardware Configuration Editor

Create a new project in STEP 7:

Step Tasks Result:

1 Select the File > New... menu command.
Enter a name for your project and click on OK to
confirm.

A new project is created

Add a new S7-300 station

Step Tasks Result:

1 Select the Insert > Station > SIMATIC 300 Station
menu command.

The SIMATIC 300 (1) icon in the
right-hand part of the window is
highlighted.

Add a rail

Step Tasks Result:

1 In the right-hand part of the window, double-click first
on the SIMATIC 300(1) icon and then on the Hardware
icon.

The hardware configuration editor 
(HW Config) opens.

2 You can insert your hardware components from the 
hardware catalog in the left-hand part of the window.

If no catalog is displayed, activate the catalog using
the View > Catalog menu command.

In the hardware catalog, navigate to Rack-300
via SIMATIC 300. Copy the rail by dragging and
dropping it in the right-hand part of the window.

The rail is inserted in the right-hand
part of the window

Add the power supply:

Step Tasks Result:

1 In the hardware catalog, navigate to PS-300. 
Drag your power supply and drop it into slot 1 on the
rail.

Note:
You can click on the power supply to display its order
number. The order number then appears in the box
beneath the catalog.

The power supply module is inserted
into slot 1.
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Add the CPU:

Step Tasks Result:

1 In the hardware catalog, navigate to CPU-300. 
Drag your CPU and drop it into slot 2 on the rail.

The CPU is inserted into slot 2.

Add the digital input and output modules:

Step Tasks Result:

1 In the hardware catalog, navigate to DI-300 via
SM-300 and select your digital input module.

Drag the digital input module to the rail
and drop it into slot 4.

The digital input module is inserted into
slot 4.

2 In the hardware catalog, navigate to DO-300 via
SM-300 and select your digital output module.

Drag the digital output module to the rail
and drop it into slot 5.

The digital output module is inserted into
slot 5.

Save and compile your configuration:

Step Tasks Result:

1 Select the Save and Compile command from the
Station  menu.

The hardware configuration is
compiled and saved.

2 Close the editor. The editor is closed. The CPU now
appears in the station in SIMATIC
Manager.
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5. Programming the Circuit

Step Tasks Result:

1 In the right-hand part of the window, first double-click 
on the CPU icon, then on the S7 program(1) icon, then
on the Blocks icon
and finally on the OB1 icon.

The “Properties” dialog for OB1 is
displayed.

2 From the properties for the organizational
block, select the ladder diagram development
language. Click on OK to confirm.

The program editor opens.

3 From the properties for the organizational
block, select the ladder diagram development
language. Confirm with OK.

The program editor opens.

4 Carefully click on the horizontal line representing the
current path.

The line is highlighted.

5 On the toolbar, click twice on the 
–||– icon (normally-open contact) and then once on the
–( ) icon (coil).

The icons are inserted into the 
current path.

6 Click on  the red question mark for the left-hand
normally-open contact in the current path.

The normally-open contact is
highlighted and the question mark is
replaced
with a text input box containing the
cursor.

7 Enter E124.1 and press Return. The left-hand normally-open contact
is now called E124.1.



13
S7-300 Automation System CPU 31x: Commissioning
A5E00164278-02

Tasks Result:Step

8 Label the right-hand switch E124.2  and the coil A124.0 in the same way.

9 set the 
File > Close menu command to close the editor, and
click Yes when you are prompted to save.

The editor is closed and OB 1 is
saved.
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6. Test Run

Step Tasks Result:

1 Navigate via SIMATIC 300 Station and your CPU to
the S7 program.

In SIMATIC Manager, click on Blocks in the right-hand
part of the window.

Blocks is highlighted.

2 From the Target System menu, select Download to
transfer the program and hardware configuration to the
CPU.
Click on Yes in every dialog box that appears.

The program and configuration are
downloaded from the programming
device to the CPU. The program
stored on the micro memory card (in
the download memory) is now
protected, even in the event of a
power failure or memory reset.

3 Switch the CPU mode selector to RUN. The STOP LED goes out. The RUN
LED starts flashing and then stays
on.

4 Actuate the two switches alternately. The LEDs of both inputs light up
alternately.

5 Actuate the two switches simultaneously. The LEDs of both inputs light up
together.

The LED of the first output lights up.

This would switch on any connected
actuator or indicator.

Diagnostics / Troubleshooting

Incorrect operation, wiring or hardware configuration can result in faults. The CPU
indicates these faults after a memory reset with the group error LED SF.

The S7-300 Installation Manual describes how to diagnose these errors and
messages.

Manuals for further details

For further information on Getting Started, we recommend that you read Getting
Started, First Steps and Exercises with STEP 7 V5.1.



Service & Support on the Internet

 To supplement our documentation, you can access our complete knowledge base
online on the Internet at:

http://www.siemens.com/automation/service&support

There you can find:

• the newsletter, which contains the latest information about your products.

• exactly the right documents for your needs via the search function in Service &
Support.

• a forum that allows users and specialists around the world to swap their
experiences.

• your local service partner for Automation & Drives in our Partner Database.

• information about on-site service, repairs and spare parts. This and much more
can be found in the ”Services” section.
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Introduction
This guide takes you through 6 commissioning steps to set up a functioning appli-
cation by running through a concrete example. In this way you will get to know the
basic hardware and software functions of your CPU 31xC.
You should expect to spend approximately 1.5 to 2 hours on this example, depen-
ding on the level of your experience.

Prerequisites
The following prerequisites must be fulfilled:

� You must be familiar with the fundamentals of electronic/electrical engineering
and have experience of working with computers and Microsoft Win-
dows#95/98/NT.

!
Warning

The S7-300 is used as a component in installations and systems that require you
to comply with specific rules and regulations that vary depending on the applica-
tion.
Please note the relevant safety and accident-prevention regulations, such as IEC
204 (emergency stop systems).
Non-compliance with these regulations can result in serious injury and damage to
both machinery and equipment.

Materials and Tools Required

Quantity Item Order Number (SIEMENS)

1 Rail e.g. 6ES7 390-1AE80-0AA0

1 PS 307 power supply (PS) e.g. 6ES7 307-1EA00-0AA0

1 CPU 31xC, z. B. CPU 313C e.g. 6ES7 313-5BE00-0AB0

1 SIMATIC Micro Memory Card (MMC) e.g. 6ES7 953-8LL00-0AA0

2 40-pin front connector with screw-type contacts 6ES7 392-1AM00-0AA0

1 � Programming device (PG) with MPI interface and installed
STEP 7 version � 5.1 + SP 2 and PG cable or

� PC with the corresponding interface card

Depends on configuration

X m PROFIBUS-DP cable with bus connectors Depends on type

Various M6 screws and nuts (length depends on installation location)
with appropriate screwdriver/wrench

Standard

1 Screwdriver with 3.5 mm blade Standard

1 Screwdriver with 4.5 mm blade Standard

1 Diagonal cutter and tool for insulation stripping Standard

1 Tool for pressing on wire-end ferrules Standard

X m Cable for grounding the rail with 10 mm2 cross-section with
cable lug for M6, length dependent on local requirements

Standard

Approx.
2 m

Stranded wire with 1 mm2 cross-section with appropriate
wire-end ferrules (type A, length 6 mm)

Standard

X m 3-core power cable (AC 230/120 V) with shock-proof plug;
length dependent on local requirements; correct wire-end

Standard

2 1-pin on switch (24 V) Standard
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Layout of the example

Power supply
ON/OFF

Switch for setting
system voltage

Programming
device with

STEP 7 software

I124.1

Q124.0

Overview of the layout of the example

+

24 Volt

Switches
Clamp for
strain relief Power connector Programming device cable

Mode selector switch Rail

SF
BF

DC5V

FRCE

RUN

STOP

RUN
STOP
MRES

I124.2

0 0
1 1
2 2
3 3

5 5
4 4

6 6
7 7

0
1
2
3

5
4

6
7

0
1
2
3

5
4

6
7

0
1
2
3

5
4

6
7

Functionality of the Example
Output Q124.0 can only be switched (i.e. the Q124.0 diode lights up on the DO), if
switches I124.1 and I124.2 are pressed.

Step 1: Installation
Installation sequence: from left to right: power module 307 � CPU 313C.
The picture shows the overview of the entire installation.

Figure Installing and Grounding the Rail

3.

1.

1. Put the rail in position and fasten (screw size: M6)
so that there is at least 40 mm of space above and
below the rail.

2. If you fasten the rail to a grounded metal plate or a
grounded device support, make sure there is a low-
resistance connection between the rail and the ba-
se.

3.

3. Connect the rail to the protective conductor. There is
an M6 protective conductor screw on the rail for this
purpose.

Minimum cross-section of the cable to the protective
conductor: 10 mm2.
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Figure Mounting the Module on the Rack

12

3

1. Attach the PS, push it up to the
grounding screw of the rail and
tighten it.

2. Attach the CPU (1), push it up to
the module on the left (2) and tip it
downward (3).

0.8 � 1.1 Nm

4

3. Screw the CPU on tightly.

4. Insert the Micro Memory Card in
the CPU (4). This is absolutely ne-
cessary for operation
A Micro Memory Card with un-
known content should be first dele-
ted in the programming device.

Step 2: Wiring

!
Warning

You can come into contact with live wires if the PS 307 is switched on or the PS
network cable is connected to the power.
Only wire the S7-300 in a deenergized state!

Stage Wiring the Power Supply and the CPU

1 Open the front doors of the power module and the CPU.

2 Loosen the clamp for the power module strain relief (see the figure on page 3).

3 Strip the power cable, attach wire-end ferrules, if necessary (for multi-wire cables), and attach
to the PS.

4 Tighten the clamp for the strain relief.

5 Insert two short connection cables between the power module and the CPU (see picture on
page 3) and tighten it.

6 Check that the line voltage selector switch is set to your line voltage.

The power module is set in the factory to a line voltage of AC 230 V. To change the voltage,
proceed as follows: Remove the protective cap with a screwdriver, set the switch to the line
voltage required and replace the protective cap.
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Stage Wiring the Front Connectors of the DI and DO

1 Open the front doors of the CPU 313C.

2 Position the front connectors so that you can wire them:
To do this, push a front connector into the CPU until it snaps into position. The front connector
still sticks out of the module in this position. A wired front connector has no contact with the
module in the wiring position.

3 Strip 6 mm from the wire ends you want to insert in the front connector and attach appropriate
wire-end ferrules.

4 Wire the front connector (DI side) as follows:
Terminal 1: L+ of the power module; terminal 3: switch 1; terminal 4: switch 2; terminal 20: M of
the popwer module.

5 Wire the front connector (DO side)as follows:
Terminals 21 and 31: L+ of the power module; terminal 30: M of the power module.

6 Wire the free wire ends of the switches to L+ of the power module.

7 Lead the wires downward out of the front connectors.

8 Tighten the front connector (this sets the connection to the module ).

9 Close the front cover of the power module and the front door of the CPU.

Step 3: Commissioning the Hardware

Stage What to Do Result

1 Connect the programming device to the CPU with the programming device cable. If you use a
cable with PROFIBUS connectors, you will have to turn on the resistors in the connectors.
Close the front door of the CPU and put the mode selector switch to STOP.

2 Connect the power cable to the network and switch on
the PS 307 power supply module.

The DC24V LED lights up on the PS.

All the LEDs on the CPU come on
briefly; the SF LED and the DC5V
LED remain on. The STOP LED
starts to flash slowly and requires
memory reset (see 3).

3 Carry out a memory reset in the CPU as follows:

� Press the mode selector switch to MRES. Keep the mode selector switch in this posi-
tion until the STOP LED comes on for the second time and stays on (this takes 3 sec.).
You can let go of  the mode selector.

� Within 3 sec. you must press the mode selector switch back to MRES. The STOP LED
starts to flash rapidly and the CPU carries out a memory reset. You can let go of  the
mode selector. When the STOP LED comes on permanently again, the CPU has com-
pleted the memory reset.

4 Raise the programming device and start SIMATIC Ma-
nager on the Windows desktop.

A SIMATIC Manager window ap-
pears.

5 Activate switch 1. The I124.1 LED on the DI comes on.
No LEDs light up on the DO.

6 Activate switch 2. Die I124.2 LED on the DI comes on.
No LEDs light up on the DO.
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Step 4: Commissioning the Hardware

Stage What to Do Result

1 Follow the STEP 7 new project assistant on the pro-
gramming device and create a new project with the
following data:

� CPU type: CPU 313C.

� Block to be created: OB1

� Project name: S7_Pro1

A two-part window with the title
S7_Pro1 --... appears.

2 Double-click the OB1 icon in the right-hand part of the
window.

The editor for the OB1 block opens.

3 From the View menu, choose the LAD command to
switch to the LAD programming language.

In the lower-left part of the window, a
rung current path is displayed in the
network.

4 Click exactly on the horizontal line of the rung current
path.

The line is highlighted.

5 Double-click the �||� button (normally open contact) on
the toolbar and then click the �( ) button once (coil).

The icons are inserted in the rung
current path.

6 Click the red question mark of the normally open con-
tact on the left in the rung current path.

The normally open contact is high-
lighted, and a text box with a cursor
appears at the point of the question
mark.

7 Enter I124.1 and press Return. The normally open contact on the left
is assigned the designation I124.1.

8 Label the right button in the same way with I124.2 and the coil with Q124.0.
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Stage What to Do Result

9 Close the editor and confirm that you want to save with
Yes.

The editor closes, and the OB1 is sa-
ved.

Step 5: Configuring the Hardware

Stage Procedure Result

1 In SIMATIC Manager, click SIMATIC 300 Sta-
tion in the left-hand part of the window.

The buttons Hardware and CPU 313 C ap-
pear in the right-hand part of the window.

2 Double-click the Hardware button in the right-
hand part of the window.

The hardware configuration editor opens.

3 � If a catalog is not displayed in the right-hand
part of the window, activate the catalog by
choosing the Catalog command from the
View menu.

� Navigate to DI-300 via SIMATIC 300 and
SM-300.

� Insert the CPU 313C  with drag-and-drop to
slot 2 (the upper or lower left-hand window).

Note:
You can find out the order number if you click a
DI in the catalog. The order number of this DI
then appears in the text box under the catalog.

����

4 Check that the order number displayed for slot
2 in the lower left-hand part of the window cor-
responds to the order number on your CPU.

If necessary, widen the order number column to
display the whole order number

If yes: Continue from stage 5.

If no: Navigate in the catalog via CPU 300
to CPU 313C and replace the CPU on slot 2
with the CPU with the correct order number
from the catalog by dragging and dropping it.

5 Insert the SM 322 DO16xDC24V/0.5A whose
order number corresponds to the order number
on your DO by dragging and dropping it on 
slot 5.

6 From the Station menu, choose the Save and
Compile command.

The hardware configuration is compiled and
saved.

7 Close the editor. The editor is closed.
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Step 6: Test Run

Stage Procedure Result

1 Navigate via SIMATIC 300 Station and CPU 314(1) to
S7 Program. In SIMATIC Manager, click Blocks in the
right-hand part of the window.

Blocks is highlighted.

2 From the PLC menu, choose the Download command
to transfer the program and the hardware configuration
to the CPU.
Click Yes in all the dialog boxes that appear.

The program and configuration are
downloaded from the programming
device to the CPU. The program sto-
red on the  Micro Memory Card (in
the Load Memory)  is now  protected
against power failureand memory re-
set.

3 Switch the CPU mode selector to RUN. The STOP LED goes out. The RUN
LED starts flashing and then stays
on.

4 Operate the two switches alternately. The LEDs of the inputs I124.1 and
I124.2 light up alternately.

The LED of output Q124.0 does not
light up.

5 Operate the two switches simultaneously. The LEDs of inputs I124.1 and I124.2
light up  together.

The LED of output Q124.0 comes on.
This would switch on a connected ac-
tuator or indicator.

Diagnosis/Debugging

Incorrect operation, incorrect wiring or incorrect hardware configuration can result
in faults that the CPU indicates after a memory reset with the group error LED SF.

You can find out how to evaluate these errors and messages in the manuals: Hard-
ware and Installation ; Section 10.4 and Programming with STEP 7 V5.1 ; Chapter
21.

SIMATIC Documentation on the Internet

You can download all the manuals free of charge from the Siemens home page
http://www.ad.siemens.de/support

The Knowledge Manager on this page helps you to find the documentation you
need faster. You can exchange questions and comments about the documentation
with other users on our forum.

Siemens AG
Bereich Automatisierungs- und Antriebstechnik
Geschaeftsgebiet Industrie-Automatisierungssysteme
Postfach 4848, D-90327 Nuernberg

Siemens Aktiengesellschaft

� Siemens AG 2001-2002
Subject to change without prior notice

A5E00105538-02
Printed in the Federal Republic of Germany
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Introduction

The sample in this manual takes you through five steps, showing you how to com-
mission a fully functional application and run the drive subsequently. You are going
to get acquainted with the basic hardware and software functions and learn how to
determine and verify application-dependent parameters in this sample. The refe-
rences to the manual should give you an initial overview of the information it con-
tains.

Usually it should take no more than one or two hours to work through this sample,
depending on experience.

Prerequisites

The conditions are that:

� You have installed an S7-300 station, consisting of a power supply module and
a CPU 314C-2 DP/PtP.

� STEP 7 (>= V5.1 + Servicepack 2) is correctly installed on your PG.

� The sample projects are available, either on your CD or you have downloaded
them from the Internet.

� You have created a project for the S7-300 station.

� The PG is connected to the CPU.

� You are set up with an external 24 V DC power supply, an encoder, a drive and
the usual required accessories, e.g. front plug and wiring material.

� You have implemented hardware limit switches and EMERGENCY-OFF swit-
ches for protecting your operating staff and the system.

� The CPU is correctly connected to a power supply.

!
Warning

Depending on the field of application, your S7-300 as component in plants and sy-
stems requires special attention relating to specific rules and regulations.
Please pay attention to current regulations relating to safety and accident preven-
tion, e.g. IEC 204 (EMERGENCY-OFF devices).
Serious injury as well as damage to machines and appliances is to be expected if
you neglect these regulations.
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Structure of the Sample

Power supply
ON/OFF

Line voltage
trimming

+

24 Volt

Strain relieve
clamp Jumper cables PG cable

Mode selection switch Profile rail

SF
BF

5 V DC

FRCE

RUN

STOP

RUN
STOP
MRES

0 0
1 1
2 2
3 3

5 5
4 4

6 6
7 7

0
1
2
3

5
4

6
7

0
1
2
3

5
4

6
7

0
1
2
3

5
4

6
7

Programming device
with 

STEP 7 software

1st step: Wiring

!
Warning

You risk contact to live wires if the PS 307 power supply module is switched on or
if the power line of the PS is connected to mains.
Wire the S7-300 only after you have switched off power!

Step Wire the power supply to the CPU

1 Connect the wired front plug to the CPU and screw fasten it.

2 Connect the I/O voltage supply:

� 24 V to X2, pin 1 and 21

� Ground to X2, pin 20 and 30

3 Connect the incremental encoder to the 24–V power supply.

4 Connect the encoder signals (X2, Pin 2 to 4).

5 Connect the power unit to the power supply.

6 Connect the power unit  signal lines, using shielded cables (X1, Pin 16 or 17 and Pin 20,
as well as X2, Pin 28 and 30).

7 Strip the cable insulation and connect the shielding to the shielding terminator. Use the
shielding terminals.
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21
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Power unit
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The pin-out below shows only the connections relevant for the respective positio-
ning mode. The other connections are found in the Manual, Chapter “Wiring”.

CONNECTOR X1:

Pin Name/Address Function

16 AO 0 (V) Voltage source, power unit

17 AO 0 (A) Current source, power unit

20 Mana Analog ground

CONNECTOR X2:

Pin Name/Address Function

1 1 L+ 24 V supply voltage for the inputs

2 DI+0.0 Encoder signal A

3 DI+0.1 Encoder signal B

4 DI+0.2 Encoder signal N

5 DI+0.3 Length measurement

6 DI+0.4 Reference-point switch

20 1 M Chassis ground

21 2 L+ 24 V supply voltage for the outputs

28 DO+0.6 CONV_EN Power unit enable

30 2 M Chassis ground

2nd step: Installing a sample project

You have two options of installing a sample project:

From CD:

Step Action Result

1 Start installation with a double-click on SE-
TUP.EXE in the SETUP folder of your CD.

The installation program starts.

2 Follow the instructions on the screen.

Download from the Internet:

Step Action Result

1 Open the sample project directory. Start the
installation program per double-click on SE-
TUP.EXE.

The installation program starts.

2 Follow the instructions on the screen.
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3rd Step: Assigning parameters

Step Action Result

1 Open your project in SIMATIC Manager. A split window opens, showing in
the header your project name.

2 In your project, call the configuration table HW Config.

3 Double-click on the submodule “AI5/AO”. The “Properties AI5/AO2” dialog
opens.

4 Disable analog output 0 per left–click on the “Output
mode” field of the “Output” tab and select “disabled”.
Close the dialog with OK.

Analog output 0 is enabled for
controlling the motor power unit.

5 Double-click the “Positioning” submodule. The “Positioning properties” dia-
log opens.

6 Select “Positioning with analog output”. In the drive, axis and encoder tabs, customize the6 Select “Positioning with analog output”. In the drive, axis and encoder tabs, customize the
properties according to your system.

7 Confirm your entries with OK. The “Positioning properties” dia-
log closes.

8 Save your configuration to your project with 
Station > Save and compile.

Your changes are now stored in
your project.

9 While the CPU is in STOP state, download your confi-
guration via PLC > Load to module....

Data are downloaded from the
PG to your CPU.

10 Close HW Config with Station > Close. You are returned to SIMATIC Ma-
nager.
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4th step: Implementation in the user program

Step Action Result

1 In SIMATIC Manager, open the project
“ZEn26_03_TF_____31xC_Pos” in the catalog
\Siemens\STEP7\Examples via 
File > Open... > Sample projects .

A split window opens, showing in the
header your project name.

2 Double-click the S7 program 
“Analog 1 First steps”.

The right window shows the “Sour-
ces”, “Function blocks” and “Sym-
bols” folders.

3 Double-click on the “Function blocks” container. You are shown all function blocks of
the S7 program.

4 Select all function blocks and copy them to your project under 
SIMATIC 300 Station > CPU3xx > S7 Program > Function blocks.

Function block Name  Description
(in the symbol bar)

OB1: CYCLE_EXC Cyclic  program

OB100: COMPLETE RESTART Restart: Resetting the control signals

FC1: GETST_A Sample 1: ANALOG, first steps

SFB44: ANALOG SFB ANALOG

DB6: DI_ANALOG Instance DB to ANALOG

VAT_GETST_A: VAT_GETST_A: Variables table

Note: In the COMPLETE RESTART (OB 100) function block, optimize the values for
speed, acceleration, deceleration and changeover/cut–off difference.

5 In SIMATIC Manager, select 
SIMATIC 300 Station > CPU3xx > S7 Program >
Function blocks .

You are shown all function blocks of
the S7 program.

6 Download all S7 function blocks contained to your
CPU via PLC > Download to CPU (CPU in STOP
state).

The program and configuration are
downloaded from the PG to the
CPU.

5th step: Test run

Step Action Result

1 In your project directory “Function blocks”, double– You are shown the table of variables
click on the VAT “VAT_GETST_A”. for monitoring and controlling.

2 Go Online via 
PLC > Connect to > Configured CPU.

The “STOP” status of the CPU pops
up at the lower right.

3 Switch to monitoring mode via 
Variable > Monitoring.

The “Status value” column displays
the actual values of the operands.

Caution

In the next two steps of the test you are going to start up the drive.

You can stop the drive again by:

� Resetting the direction control value to 0 and enabling it

� Resetting the drive enable value to 0 and enabling it

� Switch the CPU to STOP
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Action ResultStep

4 Switch the CPU to RUN. The “RUN” status of the CPU pops
up at the lower right.

5 Now carry out these two tests. Validate the control values via Variable > Enable control
values.

“Jogging” mode
Make the following settings:

MODE_IN = 1:
Selects “Jogging” mode

DRV_EN = 1:
Drive enable

SPEED:
Speed in pulses/s

Drive start: 
DIR_P = 1: Jogging into Plus direction
DIR_M = 1: Jogging into Minus direction

Note: Positioning mode is impossible if you have
enabled the two variables DIR_P and DIR_M.

In the “Status value” column, you
can monitor the following signal sta-
tes:

ST_ENBL = 1: 
Start enabled

MOD_OUT = 1:
Current operating mode: “Jogging”

WORKING = 1: 
Running

ACT_POS: 
Actual position value

Operating mode “Relative incremental appro-
ach”
Make these settings:

MODE_IN = 4:
Select “Relative incremental approach”

DRV_EN = 1:
Drive enable

TARGET:
Distance in pulses

SPEED:
Speed in pulses/s

Drive start:
DIR_P = 1: Relative incremental approach into
Plus direction
DIR_M = 1: Relative incremental approach into
Minus direction

In the “Status value” column, you
can monitor the following signal sta-
tes:

ST_ENBL = 1:
Start enabled

MOD_OUT = 4:
Current operating mode: “Relative
incremental approach”

WORKING = 1:
Running

ACT_POS:
Actual position value

POS_RCD = 1:
In position

Diagnostics/Troubleshooting

Errors can occur as a result of operator faults, incorrect wiring or configuration con-
flicts.
How to diagnose such errors and messages is described in the Manual, Chapter
“Error handling and interrupts”.

Sample :

The “ZEn26_03_TF_____31xC_Pos” project contains further samples you can use
for orientation. You can customize all samples according to your personal applica-
tions.

���������	
����������
���

�����������
�������
����������
�
����

�����������������

��������������

����
������
��� ��!�"�#!����������$

����������
%����
���&
���
�����&�����&�����
���'�
�
���	
���
����
���'��
�(��&�
�����&
���
�����&����$�
���
���
��
��)*)*+�,-�.�����/&���'���



SIMATIC

Automation System S7-300
CPU 314C: Positioning with Digital Output

Getting Started

Edition 10/2001
A5E00105533-01



2
Automation System S7-300, Getting Started – Digital

A5E00105533-01

Introduction

The sample in this manual takes you through five steps, showing you how to com-
mission a fully functional application for running the drive. You are going to get ac-
quainted with the basic hardware and software functions and learn how to deter-
mine and verify the application-dependent parameters in this sample. References
to the manual should give you an initial overview of the information it contains.

Usually it is going to take no more than one or two hours to work through this sam-
ple, depending on experience.

Prerequisites

Condition is that:

� You have installed an S7-300 station, consisting of a power supply module and
a CPU 314C-2 DP/PtP.

� STEP 7 (>= V5.1 + Servicepack 2) is correctly installed on your PG.

� The sample projects are available, either on your CD or you have downloaded
them from the Internet.

� You have created a project for the S7-300 station.

� The PG is connected to the CPU.

� You are set up with an external 24 V DC power supply, an encoder, a drive and
the usual required accessories, e.g. front plug and wiring material.

� You have implemented hardware limit switches and EMERGENCY–OFF swit-
ches for protecting your operating staff and the system.

� The CPU is correctly connected to a power supply.

!
Warning

Depending on the field of application, your S7-300 as component in plants and
systems requires special attention relating to specific rules and regulations.
Please pay attention to current regulations on  accident prevention and safety, 
e. g. IEC 204 (EMERGENC-OFF devices).
Serious injury as well as damage to machines and appliances can result if you
neglect these regulations.
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Structure of the Sample

Power supply
ON/OFF

Line voltage
trimming

+

24 Volt

Strain relieve
clamp Jumper cables PG cable

Mode selection switch Profile rail

SF
BF

5 V DC

FRCE
RUN
STOP

RUN
STOP
MRES

0 0
1 1
2 2
3 3

5 5
4 4

6 6
7 7

0
1
2
3

5
4

6
7

0
1
2
3

5
4

6
7

0
1
2
3

5
4

6
7

Programming device
with 

STEP 7 software

1st step: Wiring

!
Warning

You risk contacting live wires if the PS 307 power supply module is switched on or
if the power supply line of the PS is connected to mains.
Wire the S7-300 only after you have switched off power!

Step Wire the power supply to the CPU

1 Connect the wired front plug to the CPU and screw fasten it.

2 Connect the voltage supply of the digital I/O:

� 24 V to X2, pin 1 and 31

� Ground to X2, pin 20 and 40

3 Connect the incremental encoder to the 24–V power supply.

4 Connect the encoder signals (X2, pin 2 ... 4).

5 Connect the relay circuit to the power supply.

6 Connect all lines of the relay circuit (X2, pin 32 to 35 and pin 40).

7 Strip the cable insulation and connect the shielding to the shielding terminator. Use shiel-
ding terminals.
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The pin-out below shows only the connections relevant for the respective positio-
ning mode. The other connections are found in the Manual, Chapter “Wiring”.

CONNECTOR X2:

Pin Name/Address Function

1 1 L+ 24 V supply voltage for the inputs

2 DI+0.0 Encoder signal A

3 DI+0.1 Encoder signal B

4 DI+0.2 Encoder signal N

5 DI+0.3 Length measurement

6 DI+0.4 Reference-point switch

20 1 M Chassis ground

31 3 L+ 24 V supply voltage for the outputs

32 DO+1.0 Digital output Q0

33 DO+1.1 Digital output Q1

34 DO+1.2 Digital output Q2

35 DO+1.3 Digital output Q3

40 3 M Chassis ground

2nd step: Installing a sample project

You have two options of installing a sample project:

From CD:

Step Action Result

1 Double-click on SETUP.EXE in the SETUP fol-
der of your CD.

The installation program starts.

2 Follow the on–screen instructions.

Download from the Internet:

Step Action Result

1 Open the sample project directory. Double-click
on SETUP.EXE.

The installation program starts.

2 Follow the on-screen instructions.
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3rd step: Assigning parameters

Step Action Result

1 Open your project in SIMATIC Manager. A split window opens, showing in the
header your project name.

2 In your project, call the configuration table HW Config.

3 Double-click on the “Positioning” submodule. The “Positioning properties” dialog
opens.

4 Select “Positioning with digital outputs”. In the drive, axis and encoder tabs, customize the4 Select “Positioning with digital outputs”. In the drive, axis and encoder tabs, customize the
components according to your system.

5 Confirm your entries with OK. The “Positioning properties” dialog clo-
ses.

6 Save your configuration to your project with
Station > Save and compile.

Your changes are now stored in your
project.

7 While the CPU is in STOP state, download this
configuration via PLC > Load to module....

Data are downloaded from the PG to
your CPU.

8 Close HW Config with Station > Close. You are returned to SIMATIC Manager.
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4th step: Implementation in the user program

Step Action Result

1 In SIMATIC Manager, open the project
“ZEn26_03_TF_____31xC_Pos” in the catalog
\Siemens\STEP7\Examples via 
File > Open... > Sample projects .

A split window opens, showing your pro-
ject name in the header.

2 Double-click the S7 program 
“Digital 1 First steps”.

The right window shows the “Sources”,
“Function blocks” and “Symbols” folders.

3 Double-click on the “Function blocks” container. You are shown all function blocks of the
S7 program.

4 Select all function blocks and copy them to your project directory 
SIMATIC 300 Station > CPU3xx > S7 Program > Function blocks.

Function block Name  Description
(in the symbol bar)

OB1: CYCLE_EXC Cyclic  program

OB100: COMPLETE RESTART Restart: Resetting the control signals

FC 1 GETST_D DIGITAL, First steps

SFB46: DIGITAL SFB POS DIGITAL

DB6: DI_DIGITAL Instance DB to SFB DIGITAL

VAT_GETST_A: VAT_GETST_A: Variable table

Note: In the COMPLETE RESTART (OB 100) function block, customize the values for the
changeover/cut-off difference.

5 In SIMATIC Manager, select 
SIMATIC 300 Station > CPU3xx > S7 Pro-
gram > Function blocks .

You are shown all function blocks of the
S7 program.

6 Download all S7 function blocks contained to
your CPU with PLC > Download to CPU (CPU
in STOP state).

The program and configuration are
downloaded from the PG to the CPU.

5th step: Test run

Step Action Result

1 In your project directory “Function blocks”, You are shown the table of variables for
double-click on the VAT “VAT_GETST_A”. monitoring and controlling.

2 Go Online via 
PLC > Connect to > Configured CPU.

The “STOP” status of the CPU pops up
at the lower right.

3 Switch to monitoring mode via 
Variable > Monitoring.

The “Status value” column displays the
actual values of the operands.

Caution
In the next two steps of your test you are going to start up the drive.

You can stop the drive again by:

� Resetting the direction control value to 0 and enabling it

� Resetting the drive enable value to 0 and enabling it

� Switch the CPU to STOP

4 Switch the CPU to RUN. The “RUN” status of the CPU pops up at
the lower right.
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Action ResultStep

5 Make the following tests. Validate the control values via Variable > Enable control va-
lues.

“Jogging” mode
Customize as follows:

MODE_IN = 1:
Select “Jogging” mode

DRV_EN = 1:
Drive enable

SPEED:
Speed, 0 = Creep, 1 = Rapid

Drive start:
DIR_P = 1: Jogging into Plus direction
DIR_M = 1: Jogging into Minus direction

Note: Positioning mode is impossible if you
enable the two variables DIR_P and DIR_M.

In the “Status value” column, you can
monitor the following signal states:

ST_ENBL = 1:
Start enabled

MOD_OUT = 1:
Current operating mode: “Jogging”

WORKING = 1:
Running

ACT_POS:
Actual position value

Operating mode “Relative incremental ap-
proach”
Make these settings:

MODE_IN = 4: 
Select “Relative incremental approach”

DRV_EN = 1:
Drive enable

TARGET:
Distance in pulses

SPEED:
Speed, 0 = Creep, 1 = Rapid

Drive start:
DIR_P = 1: Relative incremental approach into
Plus direction
DIR_M = 1: Relative incremental approach into
Minus direction

In the “Status value” column, you can
monitor the following signal states:

ST_ENBL = 1:
Start enabled

MOD_OUT = 4:
Current operating mode: “Relative incre-
mental approach”

WORKING = 1:
Running

ACT_POS:
Actual position value

POS_RCD = 1:
In position

Diagnostics/Fault elimination

Errors can occur as a result of operator faults, incorrect wiring or configuration con-
flicts.
How to diagnose such errors and messages is described in the manual, Chapter
“Error handling and interrupts”.

Sample :

The “ZEn26_03_TF_____31xC_Pos” project contains more samples you can use
for orientation. You can customize all samples according to your personal applica-
tions.
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Introduction

The sample in this manual takes you through five steps, showing you how to com-
mission a fully functional counter application. You are going to get acquainted with
the basic hardware and software functions and learn how to operate the counting
function.
The references to the manual should give you a first overview of the information it
contains. Additional notes relating to frequency measurement and pulse width mo-
dulation applications are found on the sample project CD.

It should take no more than one or two hours to work through this sample, depen-
ding on experience.

Prerequisites

Conditions are that:

� You have installed an S7-300 station, consisting of a power supply module and
a CPU 31xC.

� STEP 7 (>= V5.1 + Servicepack 2) is correctly installed on your PG.

� The sample projects is available, either on your CD or you have downloaded
them from the Internet.

� You have created a project for the S7-300 station.

� The PG is connected to the CPU.

� You are set up with all accessories required, e.g. front plug and wiring material.

� The CPU is connected correctly to a power supply.

!
Warning

Depending on the field of application, your S7-300 as component in plants and
systems requires special attention relating to specific rules and regulations.
Please pay attention to current regulations relating to safety and accident preven-
tion,  e.g. IEC 204 (EMERGENCY–OFF devices).
Serious injury as well as damage to machines and appliances is to be expected if
you neglect these regulations.
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Structure of the Sample

Power supply
ON/OFF

Line voltage
trimming

+

24 Volt

Strain relieve
clamp Jumper cables PG cable

Mode selection switch Profile rail

SF
BF

5 V DC

FRCE

RUN

STOP

RUN
STOP
MRES

0 0
1 1
2 2
3 3

5 5
4 4

6 6
7 7

0
1
2
3

5
4

6
7

0
1
2
3

5
4

6
7

0
1
2
3

5
4

6
7

Programming device
with 

STEP 7 software

1st step: Wiring

!
Warning

You risk contacting live wires if the PS 307 power supply module is switched on or
if the power line of the PS is connected to mains.
Wire the S7-300 only after you have switched off power!

Step Wire the power supply to the CPU

1 Connect the wired front plug to the CPU and screw fasten it.

2 Wire the connections for the “Count 1 First steps” as follows:
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The pin–out below shows only the connections relevant for the respective positio-
ning mode. The other connections are found in the Manual, Chapter “Wiring”.

CPU 312C
connection:
X1

Name/Address Sample function

2 DI+0.0 Pulse input

3 DI+0.1 Direction bit

4 DI+0.2 Hardware gate

8 DI+0.6 Latch input

12 2 M Reference potential of the supply voltage

13 1 L+ 24 V DC supply voltage

16 DO+0.2 Simulation: Pulse input -> connect to DI+0.0

17 DO+0.3 Simulation: Direction bit -> connect to DI+0.1

18 DO+0.4 Simulation: Hardware gate -> connect to
DI+0.2

19 DO+0.5 Simulation: Latch input -> connect to DI+0.6

20 1 M Reference potential of the supply voltage

Pin
CPU
313C-2
DP/PtP:
X1

CPU 313C,
314C-2
DP/PtP:
X2

Name/Address Function

1 1 L+ 24 V supply voltage for the inputs

2 DI+0.0 Pulse input

3 DI+0.1 Direction bit

4 DI+0.2 Hardware gate

16 DI+1.4 Latch input

20 1 M Reference potential of the supply voltage

21 2 L+ 24 V supply voltage for the outputs

24 DO+0.2 Simulation: Pulse input -> connect to DI+0.0

25 DO+0.3 Simulation: Direction bit -> connect to DI+0.1

26 DO+0.4 Simulation: Hardware gate -> connect to
DI+0.2

27 DO+0.5 Simulation: Latch input -> connect to
DI+1.4+1.4

30 2 M Reference potential of the supply voltage
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The figure shows, as an example, the CPU 314C with a standard plug arrangement
for CPUs with two connectors (X1 and X2).

STOP
MRES

RUN

L+ M

2nd step: Installing a sample project

You have two options of installing a sample project:

From CD:

Step Action Result

1 Double-click on SETUP.EXE in the SETUP fol-
der of your CD.

The installation program starts.

2 Follow the on–screen instructions.

Download from the Internet:

Step Action Result

1 Open the sample project directory and double-
click on SETUP.EXE.

The installation program starts.

2 Follow the on-screen instructions.



6
Automation System S7-300, Getting Started – Counting

A5E00105536-01

3rd step: Assigning parameters

Step Action Result

1 Open your project in SIMATIC Manager. A split window opens, showing in the
header your project name.

2 In your project, call the configuration table HW Config.

3 Double–click on the “Counting” submodule. The “Counting properties” dialog opens.

4 Select channel 0 and “Infinite count” mode. Make the following settings in the parameter
assignment screen forms (Since not required for commissioning, do not modify any other
settings):settings):

� Input: Hardware gate

� Output reaction: Counter value >= Comparison value

5 Confirm your entries with OK. The “Counting properties” dialog is clo-
sed.

6 Save your project configuration with Station >
Save and compile.

Your changes are now stored in your
project.

7 While the CPU is in STOP state, download this
configuration via PLC > Load to module....

Data are downloaded from the PG to
your CPU.

8 Close HW Config with Station > Close. You are returned to SIMATIC Manager.

4th step: Implementation in the user program

Step Action Result

1 In SIMATIC Manager, open the project
“ZEn26_02_TF_____31xC_Cnt” in the catalog
\Siemens\STEP7\Examples via 
File > Open... > Sample projects .

A split window opens, showing your pro-
ject name in the header.

2 Double-click the S7 program“ Count 1 First
steps”.

The right window shows the “Source”,
“Function blocks” and “Symbols” folders.
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Action ResultStep

3 Double-click on the “Function blocks” container. You are shown all function blocks of the
S7 program.

4 Copy all function blocks to your project under 
SIMATIC 300 Station > CPU3xx > S7 Program > Function blocks.

Function block Name  Description
(in the symbol bar)

OB1: CYCLE_EXC Cyclic  program

FB11: GETST_C Sample 1: COUNT, First steps

DB11: DI_GETST_C Instance DB to GETST_C

SFB47: COUNT SFB COUNT

DB16: DI_COUNT Instance DB to SFB COUNT

VAT: VAT_GETST_C Variable table

5 Copy the symbol table to your project under
SIMATIC 300 Station > CPU3xx > S7 Pro-
gram.

The symbol table is stored in your pro-
ject.

6 In SIMATIC Manager, select 
SIMATIC 300 Station > CPU3xx > S7 Pro-
gram > Function blocks .

You are shown all function blocks of the
S7 program.

7 Download all S7 function blocks contained to
your CPU with PLC > Download to CPU (CPU
in STOP state).

The program and configuration are
downloaded from the PG to the CPU.

5th step: Test run

Step Action Result

1 In your project directory “Function blocks”, You are shown the table of variables for
double–click on the VAT “VAT_GETST_C”. monitoring and controlling.

2 Go Online via PLC > Connect to > Configu-
red CPU.

The “STOP” status of the CPU pops up
at the lower right.

3 Switch to monitoring mode via 
Variable > Monitoring.

The “Status value” column displays the
actual values of the operands.

4 Switch the CPU to RUN. The “RUN” status of the CPU pops up at
the lower right.

5 In the variable S_IMP_H of the VAT, select the count pulse source:

� S_IMP_H = 0: 
The pulse source is a programmable SW clock generator. Its frequency is adjustable
via T_PULSE variable. The clock is connected to the pulse input via a digital output
(see 1st step: Wiring)

� S_IMP_H = 1: 
Specify the count pulses by manually setting and resetting the S_IMP_T variable in the
VAT.
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Action ResultStep

6 You can make the following tests.

� Starting/Stopping the counter:

– Start the counter by setting the variables
SW_GATE (SFB parameter SW gate)
and S_HWT (Simulation HW gate) in the
VAT to 1 (logical AND).

– Stop the counter by resetting S_HWT or
SW_GATE to zero.

� Loading a count value to the counter:

– JOB_ID = 01 hex (“Write counter di-
rectly”)

– JOB_VAL = Count value (-231 to +231-1)

– JOB_REQ = 1, 
job initiates at the positive edge

� You can monitor the actual counter
value at the SFB output parameter
COUNTVAL. You can view the status
of the SW or HW gate in the varia-
bles STS_GATE or STS_STRT.

� You can view the count value loaded
at the SFB output parameter
COUNTVAL. If no load error has oc-
curred, the status at the output para-
meters JOB_DONE = 1 and 
JOB_ERROR = 0.

Diagnostics/Fault elimination

Errors can occur as a result of operator faults, incorrect wiring or configuration con-
flicts.
How to diagnose such errors and messages is described in the manual, Chapter
“Error handling and interrupts”.

Samples

The “ZEn26_02_TF_____31xC_Cnt” project contains more samples you can use
for orientation. You can customize all samples according to your personal applica-
tions.
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Introduction

The sample in this manual takes you through four steps, showing you how to com-
mission a fully functional application. You are going to get acquainted with the basic
hardware and software functions and learn how to transfer data via serial interface.
The references to the manual should give you a first overview of the information it
contains.

It should take no more than one or two hours to work through this sample, depen-
ding on experience.

Prerequisites

Condition are that:

� You have an S7-300 station, consisting of a power supply module and a CPU
31C-2 PtP. The serial connection is established via the 15-pole sub-D socket at
the right side.

� STEP 7 (>= V5.1 + Servicepack 2) is correctly installed on your PG.

� The sample projects are available, either on your CD or you have downloaded
them from the Internet.

� You have created a project for the S7-300 station.

� The PG is connected to the CPU.

� You have prepared your connection partner for data transfer and connected the
required patch cord.

� The CPU is correctly connected to a power supply.

!
Warning

Depending on the field of application, your S7-300 as component in plants and
systems requires special attention relating to specific rules and regulations.
Please pay attention to current regulations on safety and for the prevention of acci-
dents, e.g. IEC 204 (EMERGENCY–OFF devices).
Serious injury as well as damage to machines and appliances is to be expected if
you neglect these regulations.

!
Warning

You risk contacting live wires if the PS 307 power supply module is switched on or
if the power line of the PS is connected to mains.
Wire the S7-300 only after you have switched off power!
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Structure of the Sample

Power supply
ON/OFF

Line voltage
trimming

+

24 Volt

Strain relieve
clamp Jumper cables PG cable

Mode selection switch Profile rail

SF
BF

5 V DC

FRCE

RUN

STOP

RUN
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MRES

0 0
1 1
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3 3

5 5
4 4

6 6
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Programming device
with 

STEP 7 software

1st step: Installing a sample project

You have two options of installing a sample project:

From CD:

Step Action Result

1 Double–click on SETUP.EXE in the SETUP fol-
der of your CD.

The installation program starts.

2 Follow the on–screen instructions.

Download from the Internet:

Step Action Result

1 Open the sample project directory and double-
click on SETUP.EXE.

The installation program starts.

2 Follow the on–screen instructions.
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2nd step: Assigning parameters

Step Action Result

1 Open your project in SIMATIC Manager. A split window opens, showing your pro-
ject name in the header.

2 In your project, call the configuration table HW Config.

3 Double–click on the “PtP” submodule. The “PtP properties” dialog opens.

4 Select the “ASCII” protocol and enter the default settings in the parameter masks with a
click on OK:

� 9600 bits/s, 8 data bits, 1 stop bit, even parity.

5 Confirm your entries with OK. The “PtP properties” dialog is closed.

6 Save your project configuration with Station >
Save and compile.

Your changes are now stored in your
project.

7 While the CPU is in STOP state, download this
configuration via PLC > Load to module....

Data are downloaded from the PG to
your CPU.

8 Close HW Config with Station > Close. You are returned to SIMATIC Manager.
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3rd step: Implementation in the user program

Step Action Result

1 In SIMATIC Manager, open the project
“ZEn26_01_TF_____31xC_PtP” in the catalog
\Siemens\STEP7\Examples via 
File > Open... > Sample projects .

A split window opens, showing your pro-
ject name in the header.

2 Double–click on the station “CPU 31xC ASCII”. Your station is opened.

3 Open the S7 program for the station CPU and
double–click on the “Function blocks” container.

You are shown all function blocks of the
S7 program.

4 With the exception of system data, select all function blocks and copy them to your project
under SIMATIC 300 Station > CPU3xx > S7 Program > Function blocks.

Function block Name  Description
(in the symbol bar)

OB1: CYCLE Cyclic program processing

OB100: RESTART Startup processing Restart

DB21: SEND IDB Instance DB to SFB SEND_PTP

DB22: RCV IDB Instance DB to SFB RCV_PTP

DB40: SEND WORK DB Work DB for SFB SEND_PTP

DB41: RCV WORK DB Work DB for SFB RCV_PTP

DB42: SEND SRC DB Send DB

DB43: RCV DST DB Receive DB

SFB60: SEND_PTP Send SFB for data

SFB61: RCV_PTP Receive SFB for data

FB21: SEND Send data

FB22: RECEIVE Receive data

VAT1: - VAT1

5 In SIMATIC Manager, select 
SIMATIC 300 Station > CPU3xx > S7 Pro-
gram > Function blocks .

You are shown all function blocks of the
S7 program.

6 Download all S7 function blocks contained to
your CPU with PLC > Download to CPU (CPU
in STOP state).

The program and configuration are
downloaded from the PG to the CPU.

4th step: Test run

Step Action Result

1 In your project directory “Function blocks”, You are shown the table of variables for
double–click on the table of variables “VAT1”. monitoring and controlling.

2 Go Online via PLC > Connect to > Configu-
red CPU.

The “STOP” status of the CPU pops up
at the lower right.
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Action ResultStep

3 Switch to monitoring mode via 
Variable > Monitoring.

The “Status value” column displays the
actual values of the operands.

4 Switch the CPU to RUN. The “RUN” status of the CPU pops up at
the lower right. Data transfer is started.
You can view the number of transmis-
sions at the operand “DB42.DBW0”
(Send counter). “DB41.DBW18” (Re-
ceive counter) indicates receiving of
data.

Diagnostics/Fault elimination

Errors can occur as a result of operator fault, incorrect wiring of the serial interface
or configuration conflicts.
How to diagnose such errors and messages is described in the manual, Chapter
“Error handling and interrupts”.

Sample :

The “ZEn26_01_TF_____31xC_PtP” project contains more samples you can use
for orientation. You can customize all samples according to your personal applica-
tions.
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Introduction

The practical sample in this manual takes you through four steps, showing you how
to commission a fully functional application. You are going learn how determine and
configure application dependent data and how to operate a control circuit. The refe-
rences to the manual should give you a first overview of the information it contains.

Usually it should take no more one or two hours to work through this sample, de-
pending on experience.

Prerequisites

Conditions ar that:

� You have installed an S7-300 station, consisting of a power supply module and
a CPU 313C or 314C.

� STEP 7 (>= V5.1 + Servicepack 2) is correctly installed on your PG.

� The sample projects are available, either on your CD or you have downloaded
them from the Internet.

� You have created a project for the S7-300 station.

� The PG is connected to the CPU.

� The CPU is correctly connected to a power supply.

� I/O wiring is not required for this sample.

!
Warning

Depending on the field of application, your S7-300 as component in plants and
systems requires special attention relating to specific rules and regulations.
Please pay attention to current regulations on safety and the prevention of acci-
dents, 
 e.g. IEC 204 (EMERGENCY–OFF devices).
Serious injury as well as damage to machines and appliances is to be expected if
you neglect these regulations.

!
Warning

You risk contacting live wires if the PS 307 power supply module is switched on or
if the power line of the PS is connected to mains.
Wire the S7-300 only after you have switched off power!
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Structure of the Sample

Power supply
ON/OFF
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STEP 7 software

1. step: Installing a sample project

You have two options of installing a sample project:

From CD:

Step Action Result

1 Double-click on SETUP.EXE in the SETUP fol-
der of your CD.

The installation program starts.

2 Follow the on-screen instructions.

Download from the Internet:

Step Action Result

1 Open the sample project directory and double–
click on SETUP.EXE.

The installation program starts.

2 Follow the on–screen instructions.
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2nd step: Implementation in the user program

Step Action Result

1 In SIMATIC Manager, open the project
“ZEn26_04_TF_____31xC_PID” in the catalog
\Siemens\STEP7\Examples via 
File > Open... > Sample projects .

A split window opens, showing your pro-
ject name in the header.

2 Double-click the S7 program 
“Controlling  2 CONT_C”.

 The right window shows the “Source”,
“Function blocks” and “Symbols” folders.

3 Double–click on the “Function blocks” contai-
ner.

You are shown all function blocks of the
S7 program.

4 With the exception of system data, select all function blocks and copy them to your project
directory 
SIMATIC 300 Station > CPU3xx > S7 Program > Function blocks.

Function block Name  Description
(in the symbol bar)

OB100: RESTART Restart OBOB100: RESTART Restart OB

OB35: CYC_INT5 Time controlled OB: 100 ms

SFB41: CONT_C Continuous PID controller

FB100: PROC_C Control circuit for the continuous controller

DB100: DI_PROC_C Instance DB to PROC_C

DB101 DI_CONT_C Instance DB to CONT_C

VAT1: VAT 1 Variable table

3rd step: Assigning parameters

Step Action Result

1 Start the parameter assignment screen form via
SIMATIC / STEP7 / Configure PID Control.

The input dialog
“PID Control” is displayed.

2 In PID control, open your project with File >
Open. Select instance DB101 for SFB 41 and
confirm the dialog with OK.

You are returned to the parameter as-
signment screen form. The configured
parameters are displayed. Changes to
this sample program are not required.

3 Close the parameter assignment screen form
with File > Close.

The parameter assignment screen form
is closed.

4 In SIMATIC Manager, select 
SIMATIC 300 Station > CPU3xx > S7 Pro-
gram > Function blocks .

You are shown all function blocks of the
S7 program.

5 Download all S7 function blocks contained to
your CPU with PLC > Download to CPU (CPU
in STOP state).

The program and configuration are
downloaded from the PG to the CPU.
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4th step: Test run

Step Action Result

1 In your project directory “Function blocks”, You are shown the table of variables for
double–click on the table of variables “VAT1”. monitoring and controlling.

2 Go Online via PLC > Connect to > Configu-
red CPU.

The “STOP” status of the CPU pops up
at the lower right.

3 Switch to monitoring mode via 
Variable > Monitoring.

The “Status value” column displays the
actual values of the operands.

4 Switch the CPU to RUN. The “RUN” status of the CPU pops up at
the lower right. The controller is started.

5 Modify the setpoint “SP_INT” You can monitor the output value
“OUTV” that is proportional to the setpo-
int “SP_INT”.

6 Call the STEP 7 tool PID Control (see step 3).
Select IDB101 and click on “Online” mode. In
the “Test” menu, select and start the curve plot-
ter function.

You can view the graphic profile of some
of the control variables (actual value,
setpoint, control offset etc.).

Diagnostics/Fault elimination

Errors can occur as a result of operator faults or configuration conflicts. How to dia-
gnose such errors and messages is described in the manual, Chapter “Error hand-
ling and interrupts”.

Sample :

The “ZEn26_04_TF_____31xC_PID” project contains further samples you can use
for orientation. You can customize all samples according to your personal applica-
tions.
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Introduction

In this sample project, you will configure the CPU 317-2 PN/DP PROFInet interface
X2. You should expect to spend between one and two hours on this example, de-
pending on your level of experience.

Area of Validity

CPU Order no. Is MMC required As of version
for operation?

Firmware Hardware

317-2 PN/DP 6ES7317-2EJ10-0AB
0

Yes
V2.2.0

01

Requirements

� You are familiar with the basics of electronics/electrical engineering,

� Idealy, you already have some knowledge in the network technolgy field.

� You have already worked with the STEP7 programming software.

� We expect that you have experience working with Microsoft  Windows .

!
Warning

When using the S7-300 as a component of plants and systems, you may be requi-
red to follow certain rules and regulations according to the specific application.
Please note the applicable safety and accident prevention regulations, such as
IEC 204 (emergency stop systems).

Non-compliance with these regulations can result in serious injury and damage to
both machinery and equipment.
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Materials and Tools Required

Quantity Item Order number (Siemens)

1 Rail e.g.  6ES7 390-1AE80-0AA0

1 Power supply (PS) e.g.  6ES7 307-1EA00-0AA0

1 CPU317-2 PN/DP 6ES7317-2EJ10-0AB0

1 Micro Memory Card (MMC) 

Note: 
The MMC mandatory for the operation of the CPU .

e.g. 6ES7 953-8LL00-0AA0

1 � Programming device (PG) or PC with a corresponding

MPI slot card

� PG cable

� installed Software STEP 7, Firmware version 5.3.

Depends on configuration

1 Industrial Ethernet Twisted Pair cable (Cat5) with RJ45
connectors

(Patch cable TP Cord RJ45/RJ45, length 6 m)

For example, 6XV1 850-2GH60

Various M6 screws and nuts (length depends on installation loca-
tion) with suitable screwdriver / wrench

Standard

1 Screwdriver with 3.5 mm blade Standard

1 Screwdriver with 4.5 mm blade Standard

1 Side cutter and cable stripper Standard

1 Crimp tool Standard

X m Cable with 10 mm2 cross-section for grounding the rail
and suitable cable lug for M6 screw. Length of cable de-
pends on local requirements.

Standard

X m 3-core flexible power cable (AC 230/120 V) with shock-
proof plug; length dependant on local requirements, with
suitable
ferrules and insulating collar.

Standard
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Configuration

CPU
PS

Programming device (PG) with STEP7 Software

Power supply ON / OFF

For setting the line voltage

Display Slot for 

Mode selector switch

PG cable for connecting

Rail

Configuration with CPU 317-2 PN/DP

Bus error
Status and 
Error displays Micro Memory Card (MMC)

317-2 PN/DP

to the MPI interface X1
Industrial Ethernet Twisted Pair cable
for connection to the PN interface X2

Wiring the power supply and CPU (front cover open).

220 V/ 120 V
Connection cables

Strain relief

L+

M

L+

M

L+

M L+

M 24
V

 D
C

MPI interface X1 for
connecting to the PG

Power supply (PS) CPU317-2 PN/DP

Removable
power supply connection

Connection cables between the PS and CPU

Status display of the 
second interface X2

PN interface for the connection 
 to Industrial Ethernet
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1. Installation

Figure Installing and Grounding the Rail

1.

1. Screw the rail in position (screw
size: M6). Make sure that there is a
clearance of at least 40 mm above
and below the rail.

If you fasten the rail to a grounded
metal plate or device support,
make sure there is a low-resi-
stance connection between the rail

2. and the base.

2. Connect the rail to the protective
conductor. There is an M6 protec-
tive conductor screw on the rail for
this purpose.

Minimum cross-section of the cable
to the protective conductor:
10 mm2.

Figure Attaching the Modules on the Rail

1. Attach the power supply. Push it to
the left until it reaches the rail’s
grounding screw, and then screw in
place.

2. Connect to the other modules by
plugging a bus connector into the
CPU
(see detail).

12

3

3. Attach the CPU (1).

4. Push it up against the module on
the
left (2)

5. and tip it downward (3).

6. Screw the modules hand-tight onto
the rail.

7. Insert the MMC into the module
slot of the CPU: The MMC manda-
tory for the operation!

Note: 
If you want to use an MMC with
unknown contents, you should
delete the contents on the PG
first.
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2. Wiring

!
Warning

You may come into contact with live wires that are connected to the power supply.
Make sure that the S7-300 is completely disconnected before you start wiring.

Wiring the Power Supply and the CPU

Step Wiring the power supply and CPU

1 Open the front panels of the power supply and the CPU.

2 Detach the strain relief clip from the power supply.

3 Strip the flexible power cable, crimp on the ferrules and connect
them to the power supply.
(Blue to terminal M, black to terminal L1, protective conductor to terminal PE)

4 Screw the strain relief clamp in place.

5 Now wire the power supply to the CPU using the 
1 mm2 cross-section flexible cable.

Strip the ends to approx. 6 mm and crimp on the ferrules. 
Connect terminals L+ and M on the power supply to those on the CPU.

6 Check that the line voltage selector switch is set to the correct line voltage.

The power supply is set at the factory to a line voltage of AC 230 V. To change the voltage,
remove the protective cap with a screwdriver, set the switch to the required line voltage and
replace the protective cap.

3. Commissioning the Hardware

Step Tasks Result:

1 Interconnect the PG/PC and the CPU via the PG
cable. If you use a cable with PROFIBUS connectors,
you will have to switch on the terminating resistors in
the connectors.

PG/PC is connected to the CPU.

2 Connect PROFInet interface X2 of your CPU to Indu-
strial Ethernet. Use the Twisted Pair cable with the
RJ45 connectors to do this.

CPU is connected to the Industrial
Ethernet.

3 Close the front flap on the CPU and set the mode selector switch to STOP.

4 Connect the power cable to the power supply and
switch on the power supply module.

The DC24V-LED lights up on the
power supply module.

All LEDs on the CPU flash briefly; SF
LED and the DC5V-LED remain ligh-
ted. TheSTOP LED then flashes
quickly, whereby the CPU automati-
cally performs a memory reset.

The STOP LED then goes on.

5 Start up the PG/PC and start SIMATIC Manager from
the Windows desktop.

A SIMATIC Manager window opens.
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4. Configuring the Hardware in the STEP 7 Hardware Configuration Editor

Create a new project in STEP 7:

Step Tasks Result:

1 Select the File > New... menu command.
Enter a name for your project and click on OK to
confirm.

A new project is created

Add a new S7-300 station

Step Tasks Result:

1 Select the Insert > Station > SIMATIC 300 Station
menu command.

The SIMATIC 300(1) icon in the right-
hand part of the window is highligh-
ted.

Add a rail

Step Tasks Result:

1 In the right-hand part of the window, double-click first
on the SIMATIC 300(1) icon and then on the Hardware
icon.

The hardware configuration editor
(HW Config) opens.

2 You can insert your hardware components from the 

hardware catalog in the left pane of the window.

If no catalog is displayed, activate the catalog using
the View > Catalog menu command.

Navigate to the hardware catalog first via 
SIMATIC 300 to Rack 300. Using Drag&Drop, drag the
profile rail to the upper part of the HW config window

The profile rails are inserted in the
upper part of the HW config window.

Add the power supply:

Step Tasks Result:

1 Navigate to PS-300 in the hardware catalog. 
Drag the your power supply to the rail and drop it into
slot 1.

Note:
You can click on the power supply to display its order
number. The 
order number then appears in the box beneath the 
catalog.

The power supply module is inserted
into slot 1.
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Insert CPU 317-2 PN/DP and assign an IP address:

Each node in an Ethernet network is identifiable via a unique address.
The manufacturer assigns the so-called MAC address by default and you cannot
change it.

In the following steps, you will assign an IP address to this physical address in the
Ethernet.

Step Tasks Result:

1 Navigate to PS-300 in the CPU-300 hardware catalog. 
Insert CPU 317-2 PN/DP into slot 2 of the profile rail
using Drag&Drop.

The CPU 317-2 PN/DP is inserted in slo
and the Propert window  of 
PROFInet interface X2 is displayed.
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2 Specify the IP address and the subnet mask.

Your network administrator will provide you with this
information.

3 If you want to establish connection via a router, you will
have to specify the address of the router in addition.

Your network administrator will provide you with this
information.

4 Click on the “New...” button and specify a name for a
new Industrial Ethernet subnet. 
Then click on the “Ok” button.

You have created a new Industrial
Ethernet subnet.
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Tasks Result:Step

5 Click on the “Ok” button. The PROFInet interface X2 Property
window of CPU 317-2 PN/DP is clo-
sed.

6 You can now set the options for the PROFInet inter-
face in the In HW config:

In the CPU 317-2 PN/DP HW config, double-click
PROFInet interface X2.

If applicable, navigate to the Options tab, you can
make certain individual network settings here accor-
ding to your requirements.
 By default, “Automatic Settings” is selected
and this guarantees a problem-free communication
under normal circumstances. If problems occur during
communication 
(for example, if connections are not established or
if network failures occur frequently), 
this may be because the selected or automatic net-
work setting is unsuitable.

Select one of the network settings adjusted to your
network configuration.

You can perform individual network
settings
in the HW config.

Save and compile your configuration:

Step Tasks Result:

1 Select the menu command Station > Save and
Compile

The hardware configuration is compi-
led and saved.

2 Close the editor. The editor is closed. 

The CPU now appears in the station
in SIMATIC Manager.

3 Use the 
File > Close menu command to close the editor, and
click Yes

 when you are prompted to save.

The editor is closed.
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6. Commissioning

Step Tasks Result:

1 In Simatic Manager navigate to CPU 317-2 PN/DP and
then to the S7 program via 300 station.

In the right window pane, click on blocks. 

Blocks is highlighted.

2 If your PG is connected to the CPU online via the PG/
DP cable, download the hardware configuration di-
rectly to the CPU.

� In STEP 7, in the “Options”  menu> Set PG/PC
interface, set the interface of your PG/PC to MPI if
necessary.

� Select the menu command PLC > Download.
Click on Yes in every dialog box that appears. 

You cannot write the hardware configuration on the
PG to the MMC until you go offline. Then insert the
MMC into the CPU.

The programming device downloads
the configuration to the CPU.

3 Switch the CPU mode selector to RUN. The STOP LED goes out. The RUN 
LED starts flashing and then stays
on.

During a physical connection 
to the Ethernet the LINK-LED flashes.

If data is sent of recieved via Ether-
net, 
the RX/TX-LED
goes on or flashes.

Result:

You have configured the PROFInet interface X2 of your CPU 317-2 PN/DP in
STEP 7.

� The CPU is now available to other nodes on your Ethernet subnet.

� Configuration/reconfiguration is now also possible via the integrated PROFInet
interface
of the CPU.

Reference

Your will find detailed information on assigning addresses in PROFInet Interface in
the STEP 7 Online Help.
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Diagnostics / Troubleshooting

Incorrect operation, wiring or hardware configuration can result in faults. The CPU
indicates these faults after a memory reset with the group error LED 
SF.

Refer to the CPU 31xC und CPU 31x Operating Instructions for how to diagnose
such errors and messages.

Manuals for further details

� Getting Started: Working with STEP 7 V5.2.

� Manual: SIMATIC NET: Twisted-Pair and Fiber-Optic Networks

� Manual: Communication with SIMATIC

Service & Support on the Internet

To supplement our documentation, you can access our complete knowledge base
online on the Internet at:

http://www.siemens.com/automation/service&support

There you can find:

� the newsletter, which contains the latest information about your products.

� exactly the right documents for your needs via the search function in Service &
Support.

� a forum that allows users and specialists around the world to swap their expe-
riences.

� your local service partner for Automation & Drives in our Partner Database.

� information about on-site service, repairs and spare parts. This and much more
can be found in the ”Services” section.
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